Problem solved - spell check does work with Bluetooth keyboard

Fiddled with settings some more and now spell check works in Scrivener with a Bluetooth keyboard. The solution was in the combination of settings for Scrivener and the IOS 9 keyboard settings.

For anyone interested, you need to first turn off auto-correction and turn on check spelling in the Scrivener Spelling and Substitutions settings. In the iPad General/Keyboard settings, you need to turn off auto-correction and turn on check spelling, and the predictive setting. And check spelling only shows up once you have turned off auto-correction - think that is what I was missing at the start.

Now all works as expected in Scrivener - as I type with the Bluetooth keyboard, misspelled words are underlined with a red line.

Problem solved!