problem typing in Scrivener

I am having the oddest problem in Scrivener. When I type, the key I strike isn’t always the letter that appears. I’ve even typed the same letter again and again to prove to myself that I’m not just making a mistake typing.

I’ve been using the Windows Beta for several versions now with no problem, so I don’t think it’s a bug in the software. This randomly started happening weeks after I started using the last release. I uninstalled the software and reinstalled it. I’ve upgraded to version 0.2.9 this week. Still the same issue. I haven’t the same problem in Word, on Twitter, in various email programs. I haven’t any idea why this is happening and I’m so sad becasue I really miss using it. If you’ve any advice I’d be very grateful.

I have a refurbished Lenovo running Windows 7.

Are you running any programs like Constant Guard that provide anti-keystroke logging/password protection? The only other times I’ve seen this be an issue it’s had to do with a third-party tool like that. Lee is looking into it to see if there’s anything he can do on Scrivener’s end to help make it play more nicely with such software. Try logging into Windows in SafeMode (hold F8 during the boot sequence) and see if typing in Scrivener then works normally. If it does, then it definitely sounds like you’ve got some other program running in the background that’s interfering between your keyboard input and Scrivener, so we’ll just need to figure out which it is.

EDIT: Actually, one other thing that could’ve happened is that, if you have multiple keyboard layouts or languages installed, you may have switched accidentally for Scrivener. Since you can apply these per-program, it doesn’t necessarily mean that you’d have the issue anywhere else, and since the shortcuts for switching languages and layouts are Ctrl-Shift and Alt-Shift, both of which Scrivener uses in a handful of shortcuts, you may have accidentally typed it when attempting to use a shortcut. You can check your computer’s language settings in the Control Panel to see if you have other ones turned on; if you have multiple installed, you should be able to turn on the Language Bar from the task bar so you can see which language/layout is in use when Scrivener is in focus.

Thanks so much for the reply! I’ll give your suggestions a try and see how I get on.