Problem with autocorrect and substitution words

Hello,

I’m using Scrivener 3 on Windows.
It substitutes automatically some words, like (I write in French) : demander > Demeter ; quand > quet
Those are frequent french words, it’s kind of annoying. I went to Settings, Corrections, Edit Substitutions, but those substitutions don’t appear, so I have no way to suppress them.

Is it a bug or is there another way to change it ?

Thanks !

Set your dictionary to French?

It’s already in French

Try changing some of the settings at File > Options > Corrections.

I said in my post that I tried that, and the substitutions words don’t appear in the list, so I can’t suppress them

This is Mac, but I know the Windows dialog is similar. You may have to experiment.

Thanks, but as I said, I already went on this dialog and tried some things.

I can disable the substitutions, it would be the easiest way, but I need them.

If you disable substitutions, does the problem go away for those words?

Yes, it goes away. But I’d like to use the substitution. It looks like a bug…

It is possible the French dictionary is corrupted. I was able to recreate a similar scenario by messing up the French dictionary file.

You could try downloading the French dictionary again. Re-download will overwrite the existing file, so you don’t actually need to delete the file yourself.

  • From within the File->Options->Corrections->Spelling window pane, download the file.
  • Then select an alternate dictionary, such as English and click Apply.
  • Then select the French dictionary once more, and click Apply.

This will force the newer French dictionary to be reloaded. Hope this helps.

1 Like

Thank you ! It worked :slight_smile:

Well, actually, it didn’t work… I forgot to check if the substitutions were enabled… It wasn’t and when I enable it, I still have this problem.

That’s a pity!
The only other way I am able to generate your scenario is to explicitly add the annoying substitutions and then remove them.

  • Once they are added, the substitutions occur as expected.
  • If those same substitutions are then deselected from the Substitutions window, or removed entirely, followed by clicking the Apply button on the Options window, the substitutions continue to occur. This was unexpected. Although they are no longer in the list, words are still substituted.

When the project is closed (or Scrivener rebooted) and reopened, the substitutions no longer occur, it is reset correctly. This suggests a cached behaviour, the Apply button is insufficient for the Substitutions change to take effect, may be a bug.

Upon confirming there are no undesired substitutions in the list, close and reload the project and try again. I’m afraid I have no other suggestions at this stage.

Following your examples, Demander->demeter, and quand->quet.

Either deselect or remove altogether:

image

Thank you @Muse ! It doesn’t work :slightly_frowning_face:
I tried to deselect them, then suppress them, and I closed Scrivener after each change, it still substitutes those words. I tried to tell to substitute demeter by demander, but it didn’t work either.
I’ll try to find some French people to ask them.

Hi @anaisk,
It is disconcerting you are still having an issue. This is intriguing :thinking:

Is it possible for you to post some images of your settings, it might help someone to notice where the problem or bug resides?

You gave a couple problem substitution words earlier, we’ll stick with those, unless you have others too:
demander: becomes → demeter
quand: becomes → quet

If you don’t mind to post following window images:

  1. File->Options->Corrections

  2. File->Options->Corrections->Edit Substitutions (Expand window and scroll to show top and bottom of list, maybe need to attach a couple images)

  3. File->Options->Corrections->Spelling

  4. File->Options->Corrections->Spelling->Dictionary.Select… (Dictionary Selection window)

  5. File->Options->Corrections->Spelling->View Personal Word List

Does the problem occur on any project, even brand new empty projects?

Except for two scenarios mentioned earlier, I have tried to recreate the issue, but no luck so far :confused:

Hi,
Here are the screenshots, thanks !
It’s my first project, I created a brand new but it still does that. I found another word : demandent > demetent
I had trouble to remove the substititions I added after your suggestion : I had to restart Scrivener multiple times before it decided to finally delete the substitution “demander by Demeter” that I tested. It didn’t change the fact that it made the substitution, but it was weird that each time I opened Scrivener, the substitution was still on the list, deselected.

Speaking of weird things, when I added my own substitution ti > Thérapie d’Impact, it substituted “ti” inside words, so I ended with things like this “SubsThérapie d’ImpacttuThérapie d’Impacton”. I had to add a space in the substitution panel, so now, to make it work, I have to type ti then double space and it replace with the words asked.

Thank you @anaisk for the screen images. That helps.

So the issue is related to one substitution in your list, specifically the second one.
The substitution and: becomes → et

When Scrivener encounters the string of characters and it is using the substitution rule to change those three characters to the string et. Hence,

demander changes to demeter
quand changes to quet
demandent is changed to demetent

Removing or deselecting that one substitution should resolve the issue you have experienced.

With regards the 'ti->Thérapie d’Impact substitution, the behaviour is as expected for the same reason.

The substitution feature is a symbol or text replacement, not based on a word boundary. Scrivener, in my usage at least, is monitoring each keystroke. The moment it detects a sequence of characters matching those in substitution list, the next keystroke leading to another character will trigger the replacement/substitution.

For example, to display ©2021:
when (c) are typed, the next character, the digit 2, will invoke the substitution to show ©2

It is not looking for space delineated words. For the “ti” substitution you can use spaces as you have discovered, or create a more unique string, say XX, or YY, or perhaps use parenthesis, similar to some existing entries.

(ti) → Thérapie d’Impact

I hope this helps.

3 Likes

Good catch. Mysterious bug report solved.

Hi @Muse ,
Well, that’s kind of embarrassing :sweat_smile:
Thank you so much for your time and for solving a bug that wasn’t a bug ! :grinning_face_with_smiling_eyes: