Problem with importing OpenType fonts into word processors

I’ve got a problem with font replacement when I import rtf texts into word processors.

It is not a Scrivener-only problem but since at the end of a Scrivener workflow often stands the export to a dedicated word processor – and since members of this forum are extremly knowledgeable and helpful – I decided to post here too.

My standard font is an OpenType font (the problem is not related to this font alone, I tested other OpenType fonts and it was all the same).

When I export texts from Scrivener (the problem is not related to Scrivener’s rtf export, it’s just the same with TextEdit and other programs), only programs based one the Apple TextEngine will get the font right. (And NisusWriter which I don’t own.)

Other programs like and NeoOffice will recognize the font under a different name – for example as “BemboMTPro-Regular” instead of “Bembo MT Pro Regular”. Because there is no “BemboMTPro-Regular” installed I get some automatic replacements which never is “Bembo MT Pro Regular” but “Lucida” and others. Strangely NeoOffice and do not behave the same in the replacing of fonts.

Additional information I: When I open the OS font palette and show preview both font names are displayed, the “real” ones like “Bembo MT Pro Regular” and below the other ones – which actually are the file names of the fonts without extension.

Mellel, my word processor of choice, has the same problem but then again it also has a handy font replacement pop up when you import rtfs. So I chose the font replacements and set them to standard:

Font replacement.png
But it doesn’t work! The text is flattened with only the regular Bembo font.

To be more precise: When I delete the font assignings and set them again but non-permanent and only after a restart of Mellel – then it works sometimes. Yes, sometimes. That’s a bad word when you try to locate the reason for a misbehaviour of software. But it looks like Mellel has Alzheimer with rare moments of clarity.

Additional information II: I use Linotype FontExplorer X as my font manager.

Additional information III: No problems whatsoever with non-OpenType fonts. All fonts are imported correctly, no italics etc. are lost.

Has anyone here ever had the same problems? And how can they be fixed? And who’s fault is this – is it more of an OS issue than a Mellel issue?

For anyone beside me who might be interested in this:

The problem is solved. I had to clean the OS font cache and.

Now at least exporting to Mellel works fine (OpenOffice and NeoOffice still do not recognize the font correctly). Now when opening the rtf file Mellel does not detect four different fonts (regular, italic, bold, bold-italic) but just regular which gets replaced but without flattening italics and such. I don’t understand it, but it works.

Interesting about it is the fact that it only works with texts written after I had cleaned the font cache. Convert to Document Style of older texts does the trick too. The texts look exactly the same and contain exactly the same fonts but internally something changes.

Some ten years ago I wrote a utility for collecting fonts and artwork associated with Illustrator files. It was used in hundreds of prepress houses and design firms. I mention this so you can be assured the following statement is authoritative:

I won’t go into the details other than to say the font management part of the utility took nearly two months of teeth-gnashing labor to write. It is a perpetual amazement to me that fonts work as well as they do these days.

I’m delighted you were able to resolve your problem and have some suggestions for anyone with similar problems:

  1. Use Linotype FontExplorer X to manage your fonts. It is a superb font manager and it’s free. Read the documentation, it will save you time and much aggravation.

  2. Make absolutely certain you do not have multiple versions of the same font open—that way lies madness.

  3. Whenever you encounter perplexing problems like whole blocks of garbage characters or global font substitutions, clean the system and application (Adobe, Quark, and Microsoft) font caches. Restart your machine after you do it. FontExplorer can do this for you (the Tools menu) or you can use a utility like Onyx to do it.

  4. Be suspicious of “free” fonts you’ve downloaded. They’re not free—they can often cause problems because they weren’t built carefully (bad kerning tables, glyph mappings, etc.).

  5. If you are actually preparing files for publication (rather than passing them to a publisher) avoid using the standard style shortcuts (Cmd-I for italic, etc.). Select the font explicitly: Helvetica Condensed Semi-Bold; not Helvetica Condensed and then Cmd-B. The system can’t tell that semi-bold is sorta bold and that’s what you wanted.

Happy Font Management!


Dave, care to tell us what that app was? In my ‘former life’ I was a graphic designer, and also worked at a prepress bureau for a few years. I may well have used it :slight_smile:

(And I second the recommendation of FontExplorer X - it’s an excellent app, and you can’t beat the price.)

Harvest. I only supported it 'til Illustrator 9 came out and they changed the internal format to PDF. It was too monstrous of a rewrite to parse PDF as fast and as completely as I wanted so I regretfully let it go. Amusingly enough, I met a designer at a trade show a year or so ago and he still used it on occasion by saving a copy back from CS3 to 8 just to collect things. Gak!


Heh. Given that at least one national newspaper here in the UK still used Quark 3.1 until a couple of years ago, I can’t say I’m too surprised :wink: Afraid I’m not familiar with Harvest, though, sadly. Ah well.

That would have been fun if you were. :slight_smile:

If you still have a need for collecting Illustrator files, Artfiles supports up to CS3 and does a nice job.