Problem with Korean character Display[BUG LOGGED]

I’m using both Scrivener for Win and Scrivener 2.0 for Mac
Windows version is XP.

I’ve made scrivener project in Scrivener 2.0 for Mac.
Then opened the project in Scrivener for Win.
I was frightened to see all Korean characters of documents’ text, synopsis, and notes displayed weirdly.
This issue is the same in edit, corkboard and outliner modes.

Here’s are screenshot.

  1. Project opened by Scrivener 2.0 for Mac. (Korean characters displayed correctly)

  2. Project opened by Scrivener for Win. (Korean characters displayed weirdly)

I tested latest version of Scrivener for Win(29th Oct - LEE’S DAILY UPDATE).
I attached scrivener project for you to identify and reproduce this issue.
Bug Report.scriv.zip (734 KB)

I think Lee is still sorting out the issue of language directories and this will be fixed in upcoming betas.

Hallo,

it seems to me this could be the same problem like the one with german umlaute at my computer (it was not reproduceable by the developers afaik).
Just because i am curios: When you open the rtf document in the doc subfolder of your scriv file with another software, will it then be displayed correctly? (The umlaute are displayed correctly on my comp then).
I think this should have to do something with the character encoding, there are different standarts and if two systems use different standarts it can result in character-chaos. But i am far away from beeing an expert at this. I tried to work around this somehow but have found no solution until now. When you or somebody else has an idea or found a way to handle this, it would be great to hear from you then^^.

I opened the rtf document in the doc subfolder of your scriv file with MS Word.
It was displayed correctly.
I think we’re experiencing the same issue.
Thanks.

Excellent report. Thank you.