Problem with Korean character in outliner mode (Scrivener 2)

Scrivener ver. : 2.0 for Mac.
OS : 10.6

When I type title and synopsis in outliner mode in Korean, result is weird.
But when I type the same Korean characters in corkboard mode, it works fine.
I haven’t experience this kind of issue ever in scrivener ver. 1.5.
scrivener bug.jpg

Hi,

I can’t see what’s wrong in the screenshot - the correct characters all seem to appear as I’d expect. The outliner uses a different font to the corkboard - have you tried just changing the font in the preferences?

Best,
Keith

In the screenshot the correct characters are “알타이”, but in outliner mode appears as “알ㅏ타이”.
I’ve typed the same characters “, , , , , , ” in both corkboard and outliner mode.
In corkboard mode : 알타이 -> the correct character
In outliner mode : 알ㅏ타이 -> the incorrect character
The character “” is doubled.
Outliner mode seems to produce unintentional doubled type in Korean.

I’ve change font, but problems remain.
Binder also use the same font as outliner, but It works fine in binder.
This Issue only happens in outliner mode.

Ah, right, I see. Is this a display or typing issue?

Given that my knowledge of Korean is on a par with my knowledge of string theory, could you please let me know what I need to type on an English keyboard, and with what exact language settings, so that I can reproduce the issue?

Thanks,
Keith

I am writing in Korean with Scrivener 2.0. So far I had no problem with Korean characters in outliner mode - I’ve been using outliner mode very frequently.

This is a typing issue.

You can reproduce the issue in this way.

  1. Open Input sources tap in Language & Text Pane of System Preferences.

  2. Turn on “Hangul” and “2-Set Korean”. (See the screenshot below)
    scrivener bug_1.jpg

  3. Change the input source from “U.S” to “2-Set Korean” in the Menu Bar. Or use keyboard shortcut “command + space”

  4. Type “d, k, f, x, p, d, j” in order on your english keyboard.

  • In corkboard mode, it will produce “알테어” <- the correct result
  • In outliner mode, it’ll produce “알ㅔ테어” <- the wrong result

In outliner mode, title input produce the correct type result sometimes, but synopsis input always produce the wrong result.

As I’ve experienced the fantastic update in Scrivener 2, I don’t want to go back previous version. (Although this was fantastic, too)

Thanks.

Thanks, I’ve copied this into my bug log and will investigate this in the next couple of days.
All the best,
Keith

It’s never been fixed since version 2.
With korean letters, in outliner mode, I can’t change lines without break letter to consonant letter and vowel letter. Every end of line, when letters cross to next line, the first letter break into letters and it’s not supposed to be.

PLEASE FIX this. Since this problem exists, I had to use omnioutliner for making outlines and I hate this.

This was fixed a while ago. I just tried to reproduce it following goodfoot’s instructions up-thread, and everything works fine for me. If you are still seeing problems in the latest version of Scrivener (3.1.1), please provide reproduction steps, including the keys I need to type on an English keyboard.

All the best,
Keith

I think this is another issue.

You can reproduce this way.

You can follow original post’s 1) to 3) to change input source U.S to 2- set korean.

  1. in scrivener’s Preferences, set outliner font “Note Sans CJK KR DemiLight 14” (actually font doesn’t matter)


  2. in Outliner mode.


  3. Leave title section or type freely,
    In synopsys Type like this (without ")

"dlfaksgkaus qkqhrk ehlsek. "

it looks like this in korean "일만하면 바보가 된다. "

And I keep typing same set of keys 6 times.

  1. When the line breaks, letters break too.

On second line you see,

"일만하면 바보가
ㄷㅚㄴ다. "

should looks like

"일만하면 바보가
된다. "

And 3rd line,

"일만하
며ㄴ 바보가 된다. "

should looks like

"일만하
면 바보가 된다. "

And final line,

“일만하면 바보가 된다.
ㅇㅣㄹ만하면 바보가 된다.”

should be

"일만하면 바보가 된다.
일만하면 바보가 된다. "

I hope you can reproduce this issue.
In corkboard and other text input area like notepad and scratchpad, this issue does not occur.

Thank you.

Many thanks for the reproduction steps. I can reproduce it on my machine. Unfortunately, after spending a little time on this, it seems that this isn’t something I’m going to be able to fix easily or soon. The problem is down to the way the outliner has to resize, because of the way Apple’s outliner code works. There’s an issue whereby when a row height changes, the edited text area does not. This means that to force the text editor to resize, I have to listen out for row size changes, then exit editing and restart editing again, at which point the editor will be the resize. But this is exactly the problem - because the editor silently ends and restarts editing, it breaks composite characters that push the text across to the next line.

In the future I will be able to fix it. There’s a newer way of creating outlines on macOS, which is more flexibility and will allow me to use a custom editor instead of Apple’s fixed-sized one. However, this involves completely rebuilding the outliner from scratch using the new method, so it is a big job - it will take a month at least. It’s on my list for an update within the next year or so.

In the meantime, I have added an option for the next update that allows you to disable live row resizing. This way, the row will stay the same height while you type and just resize after you end typing, avoiding the bug. Another option is to use fixed row heights (View > Outliner Options > Use Fixed Row Height).

Thanks and all the best,
Keith