Problem with levels based on structure

Hi,

I have difficulties with “section based on structure”. I reworked my structure in projet parameters so level2 fits with my subfolders (see first image here), but when compiling, I still see it at level 1 (see second image below). Is there a setting I am missing?

Thank you!

Stéphane

could it be that you haven’t linked that level to the format you want for that level? Like, maybe Scrivener recognizes it as level 2, but the format you applied to it is the same as level 1, that’s why when compiling it appears to you as if they were the same.


^ below, in this box, you can link the levels to each format you have

To rule out compile setting oddities (which should not be a problem, but we might as well check):

  1. Click on “Total” in the binder.
  2. Switch the view mode to Outliner (Ctrl+3).
  3. Add the Section Type column if necessary (the button for columns is above the scrollbar), and after clicking in the outliner to focus it, View ▸ Outline ▸ Expand All (Ctrl+9).

This will show you the project’s understanding of your settings, and is an easier way to experiment than opening and closing compile. They do definitely look correct in the screenshot, and the right folders are being highlighted, so I am not sure why the compile contents view is showing “level 1”.

If they are listed correctly in the Outliner, then to troubleshoot compile: try switching back to “Paper” at the top of the Contents tab, instead of current selection.

Even though current selection flattens the selected items (so they are all “level 1” in appearance), they should still use the assigned section types, but maybe you are looking at a bug here.

Thank you for tip. Here is the screenshot. Indeed, it seems to be a bug for me.

Thanks for the tip. I see the same thing on the outliner. I feel it is a bug.

I wanted to link to a new screnshot, but it is giving me an error. And I can not post a media here, as I am a beginner, it seems. So not sure I can share my screenshot.

Best,

Stéphane

You’re okay, you posted several links, which made the forum software get a bit twitchy as a spam countermeasure. I’ve approved the posts and set your account so that you can now drag screenshot images into your posts as you write them, too, rather than using this other service.

Well since the Outliner is showing the same thing, what version of Scrivener are you using? It says in your profile 3.1, which is quite old. You might try downloading the latest version and running the installer to make sure you’re fully up to date. If you are on 32-bit you’ll need to click the “Download older versions” button and get 3.1.4.1 instead.

Indeed I do see a ticket for an old bug that was fixed, where the level numbers were off by one.

Hi,

Yes, sorry for my multiple links and thanks for the authorizations. Here is a good ssceen capture (the last one had to much information):

I have version Version : 3.1.5.1 (2073405) 64-bit for Windows.

Here is my test project that I made to copy your settings:

These look the same to me (the names of things aside). I even set the interface to French, which shouldn’t matter, but why not.

Okay, let’s try this, because there is one way to “force” the result you are seeing:

  1. Right-click on “Total” and look at its Section Layout menu. You should see something like this:

    The important thing is that Basé sur la Structure is set for both “Total” and its subdocuments.

  2. Next do the same thing for “Introduction”.

This tool would be used to override the project settings. It can be useful for things like an Appendix or Glossary, where you want the subdocuments to work different from chapters, sections and so on.

Ah ok. This was my problem . “Total” was set on level 1 text.

If I put it on “Based on structure” (Basé sur la struture), it now works.

So, If I put “level 1 text” for “sub-document”, even “sub-sub-documents” would be to “level 1 text?”.

Anyway, I guest it works. Thank you very much for this!

Stéphane

1 Like

Yes, that setting overrides everything below the level you change it on, until (and if) another folder within it sets a different subdocument default. So you can still have multi-layer Section Types, but it takes more clicking to set it up at the different levels.

Thank you very much again :slight_smile: