Problem With Research PDF Files

I have been working on a project in Scrivener for the past couple of weeks with no problem but imported some PDF files into the research section today and some of them are not working properly. 2 shorter PDFs imported without difficulty, but with any new PDFs I import, there is a chunk of the viewing area that has a white band so the PDF only shows up on part of the screen. These PDFs also cannot be highlighted/annotated as the text will not select properly. I have tried importing the files into the project and also as aliases, but with the same result. Is this a common problem? Is there a limit to the size of a PDF that can be incorporated into a Scrivener project?

Which version of OS-X are you using and which version of Scrivener? That problem has been reported before in terms of using 2.6 versions of Scrivener with older versions of OS-X, so it would help us to help you to know those factors.


Mr X (Only a user, not a dev or support person)

IIRC this is because of automatically resize being enabled, try using the context menu and change the zoom setting. This will be fixed when Scrivener 3 is released I think as it is a 32bit PDFKit bug, or something! :wink:

Thanks so much for the replies and suggestions. My OS is Yosemite and I am using Scrivener 2.7. I changed the PDF view setting to “actual size” as recommended, which did help but the files are quite small now and it would be nice to be able to zoom in. Looking forward to Scrivener 3!

As Mr. X said, this is a known issue. Details can be found here: … own-issues

You should be able to resolve the issue by viewing PDFs with Page Breaks, rather than in Continuous mode, and that should allow you to use the Zoom feature as well.


Hi, having this same problem myself.

Katherine is right that you can switch out of continuous mode by right clicking on the document and selecting it from the shorthand menu (single page instead of single page continuous). But what I also found was that, providing I don’t zoom in too far, I can then switch back to single page continuous and maintain my zoomed in level.

If I zoom in too far, switching back and forth between continuous won’t solve the problem.