Problem with Smart Quotes

Scrivener preferences are set for smart quote (Scrivener > Preferences > Corrections; Use Smart Quotes is enabled) however for some documents in my project straight quotes are not being converted at all. A few documents were written remotely and then either File > import-ed > Plain Text Formatted Screenplay or cut-and-pasted from a text file via the OS X scratchpad into Scrivener. I don’t recall which documents originate from Fountain or text files. They may or may not be the ones for which auto smart quotes fails.

The documents affected are being converted from Scriptwriting mode to Standard text mode. After switching mode I Select All and then use my own default preset. As corrections and conversion from script to narrative go on the dialogue markers are replaced with open/close quotes. However not all documents end up with smart quotes.

Format > Convert > Quotes to Smart Quotes forces the issue but it is dash inconvenient to have to check whether to do this or not.

Scrivener doesn’t manipulate text when you import it. The options in the Corrections pane are for the most part specific to adjusting how the software works while you type. I know I’m a bit weird, but I would super annoyed if I flipped that checkbox on and Scrivener started aggressively changing my quoting style as I flipped through existing documents or as I imported them. That strikes me as very presumptuous. I could be working with source code examples for instance.

Put a keyboard shortcut on the conversion command if you need it a lot, that’s what I do with commands that I find myself using multiple times per session. And it doesn’t hurt anything to use it if you don’t know whether you need to use it. It’s not going to do anything to the smart quotes that already exist.

Understand your reasoning Amber but the smart quotes are being typed! I’m manually converting the Character elements to either a tag “X said” style or more usually nothing before typing the opening and later closing quotes. Having switched from scriptwriting mode to plain text mode as I begin this reformatting exercise I expect the corrections smart quote preference to be used. It isn’t.