Problem with Table of Content

I create a table of content with copy-copy special-copy as toc. The toc shows the title, a tab stop, and the page number. When I compile to pdf the page number appears on the line below the title, meaning there is a line break. Ugly. I have one document where the TOC aligns properly and three where it doesn’t. The three that don’t work have a smaller page size.

That is likely the problem: the ToC is generated for a larger page than is actually available in the finished document.

Try creating the ToC in Page View in Scrivener, making sure that your page settings match what you’ll actually be using. That will let you see and fix any problems before compiling.

Katherine

Thanks for the input. What does that mean: “making sure that your page settings match what you’ll actually be using.”
The page settings are set to the actual size I’m publishing at createspace. I do the ToC copy and paste and after that I do not change any page settings. Also, I see no way of changing the TOC indents or formatting the TOC.

You need to make sure that the settings used for Scrivener’s Page View, which come from the File -> Page Setup command, match the settings used for your output document, which uses the File -> Compile -> Page Settings pane.

Also, in the File -> Compile -> Contents pane, check the Compile As-Is box for the ToC document.

The Format -> Show Ruler command will show tabs and indents and allow you to change them. The Format -> Options -> Show Invisibles command will show you tab characters in the ToC document itself.

Katherine

It worked. Thank you!

Thanks - I had this problem too… :slight_smile:

kewms’ answer about page size seems also to answer my unanswered question in https://forum.literatureandlatte.com/t/pdf-toc-for-hierarchical-numbering/36911/1 It also points out that Scrivener treats File => Page Setup different that Compile => Page Settings => Page Setup when doing a Edit => Copy Special => Copy as TOC. This just might be a BUG.

I have always used the Compile setting to adjust my page size, I now realize that maybe I should never use that one.