Problems deselecting text in Notes in Quick Reference Panel

I use Quick Reference Panels heavily while editing as they contain all my editing notes for each chapter (and right now, I have a lot of edits - thousands of words per chapter in some cases). So, I have the Chapter in one Quick Reference Panel and the Notes in the panel beneath.

Since upgrading to Scrivener 3, I’m having real problems selecting and deselecting large blocks of text in the Notes panel.

If you select a small amount of text - just a few lines - you can click to clear it without a problem. But if you select a lot of text, say 5-600 words, you can’t click to deselect it. It might deselect part of the selection but not all of it, and patches of text are still highlighted blue. Then, when you select another block of text to edit, part of the original is still selected and that gets the changes too.

The only way around it is to select all and deselect all.

It may seem like a small issue, but it’s wasting a lot of time and is really frustrating. I have notes from myself, my agent and my editor and I like to colour code them so I know at a glance whose are whose. Right now, I can’t select them to colour change them without constantly using the menu to deselect all.

Please help!

p.s. I’ve just realised that deselect all doesn’t always work. So now I don’t have a reliable workaround! Pretty please help! :smiley:

Do you mean in Comments and Footnotes? I don’t really see any difference between the Notes pane behaviour and the main text editor for that matter. You click somewhere and the text deselects.

But, then again I don’t have a problem selecting a bunch of text inside of a comment and clicking somewhere within that selection to deselect it either. :slight_smile:

Maybe try moving the cursor instead of using the mouse?

Hi Amber,

Thanks for responding so quickly… you always do! :smiley:

No, I don’t mean Comments and Footnotes. I’ve taken a series of screenshots so you can see what’s happening. And to be sure my project isn’t at fault, I’ve started a completely new project. To give you the steps to recreate, with screenshots, I’m having to split this across three messages as it only allows me 3 screenshots at a time.

Here are the steps to recreate:

  1. Pick the scene you wish to edit and click the ‘Open Quick Reference Panel’ button (alternatively, from the menu, Navigate, Open, as Quick Reference (Screenshot 1).

  1. From the right hand side menu option, change Editor Only to Notes. The screen will split and give you the chapter you’re working on at the top and the accompanying Notes at the bottom (Screenshot 2) I’ve resized the bottom Notes panel so you can see more clearly what’s happening.

  1. Select a large portion of text from your Notes (Screenshot 3).

cont…

cont…

  1. Make changes to the text, in my case, I’m changing the colour to red (Screenshot 4).

  1. Click anywhere to deselect and you’ll see that part of the text remains selected (Screenshot 5).

  1. Click again, it still won’t deselect. Move the cursor around and it will deselect a cursor-sized area (Screenshot 6), leaving deselected lines through the text.

cont…

cont…

  1. Re-selecting portions of text will deselect portions (Screenshot 7).

  1. The only way to properly deselect is to Select All, Deselect all from the menu (I’ve created a shortcut). But that doesn’t always work and you may have to do it a few times.

  2. You can see it happening again immediately afterwards when I try to colour the next block of text blue, again, it leaves a portion of it selected (Screenshot 8 ).

I can consistently recreate this, not only in my own project but in this new test project. The crux seems to be large blocks of text, because if I select small blocks of text at a time, it lets me deselect them without issue (Screenshot 9), as you can see I’ve recoloured small sections.

Hope you can help sort it! Let me know if you need to run any tests or gather more screenshots.

Gilly

I can replicate it using your steps— although it did take lot of words before it happened (over 1000 in my case. )

It looks like it’s a display problem – the errant text isn’t actually selected afterwards (it doesn’t respond to Copy).

That… is just bizarre. It’s certainly no behaviour of Scrivener’s - there’s no code in Scrivener that could do this. I’m wondering if an error is getting thrown that is then causing random behaviour. Could you please open up Scrivener’s Preferences, and then under General > Warnings tick “Show internal error alerts”. Restart Scrivener and then see if any errors get shown before you see this behaviour. (It’s generally best to leave “Show internal error alerts” off, because Apple’s frameworks throws several harmless errors that may interrupt your work otherwise, but it’s useful to turn it on when you see erratic behaviour like this to see if any errors are getting thrown.)

Thanks and all the best,
Keith

Hi Keith,

I did that, switched on the internal error alerts in general preferences, then restarted, then replicated the problem.

I’m assuming from your description that any errors it’s throwing should be shown directly on screen, rather than in a saved file? And if so, I’m not getting any error messages.

And BROOKTER… yes, you need a lot of text in the notes file to replicate the issue. I have thousands for chapters that need a lot of reworking.

And yes, it does appear to be just a display issue, as in, what’s selected isn’t really selected at all. Try this test to prove that point: create a test scene with Notes approx 1500 words long. Then Apple-A or use the menu to Select All. You should find that it doesn’t highlight all of the text, just a block of it. But then Copy and Paste this into a new document somewhere. You’ll see that even though it hasn’t highlighted the entire selection in blue, it still copies the entire selection!

It’s a strange one! And definitely a Scrivener 3 issue. I never had any problems managing large Notes files on Scrivener 2.

Thx!
Gilly

I don’t think it’s actually a Scrivener 3 issue but a text system issue - it might be to do with Scrivener 3 being 64-bit. But selection is entirely down to Apple, so I think the bug must be in their code (since Scrivener has no control over selection drawing). But I cannot reproduce it at all at the moment.

Hi Keith,

I’m running Mac OS High Sierra.

The day before yesterday, I was updating all my Notes in Scrivener 2 without an issue. The only thing that’s changed on my system since then is the upgrade to Scrivener 3, yesterday.

And since Brookter has also been able to replicate the issue, it can’t just be my setup.

Is there anything else I can do or provide that’ll help you get to the bottom of it?

Thanks!
Gilly

Found a real quick and easy workaround. Just hit enter anywhere in the Notes and it clears the selection. Phew! Now it’s not causing me so many problems, there’s no urgency on it at all.

Gx

Maybe a High Sierra issue, though? I’ve been trying to replicate this and have over 50K words in notes and still can’t get anything like this, but I’m only on 10.12.6. Still need to upgrade the other machine to High for testing…but weird quirks like this keep stopping me. :wink:

Hi Jennifer,

Thanks for trying to replicate. In that case, it must be a combo of Scrivener 3 and High Sierra, as I don’t have the problem with Scrivener 2 on High Sierra. Be interesting to see (if you do decide to upgrade) if the problem pops straight up.

Gilly

Just a quick addition to say, I installed the latest software update and the problem still remains. I’ve also tried large selections in a number of other applications and it appears to be unique to Scrivener. It’s clearly a display issue, as it is selecting text, even if it shows that the text isn’t selected. And it is deselecting areas that it displays as selected. But it’s not unique to notes or the quick reference panel. It happens with large blocks of text in the binder, for example, and large blocks of text in synopses.

Let me know if there’s any testing I can do to help get to the bottom of it.

Gx