Problems installing 049 beta on Windows Vista

Hi,

I have pre-ordered the windows version and downloaded the beta file to try it out.

Scrivener-049-installer.exe

But when I am trying to install, I get an error.

First of all, it says it will install

Scr73B9.temp (this changes every time I try to install)

file, and when I click on it a popup console comes up that says "(Scrivener) 1 % " and another smaller popup on top of it, and the whole thing stops installing.

I have tried to install the Nano version, same thing happens.

I understand that there is another week before I can get the final version, but wanted to try it out.

I am using windows Vista 64bit version and have tried on three more of my older laptops (one XP, two Vista), it worked on every one of them, except for this one. But this is the one with the large screen and I would like to use this to work.

I had an expired Beta version on this laptop, but I have uninstalled it to the best of my knowledge.

Anybody any idea what is wrong?

Thanks,

Just some more info: I tried to disable both Firewall and my Virus Software. None of it helped.

Assuming you downloaded the installer directly to each of your other machines, the first thing to try is clearing your browser cache on the Vista machine and then downloading again. You may have ended up with a partial or otherwise incomplete file.

If that doesn’t work, could you run go to the Windows start menu, type “cmd.exe” and then right-click the result and choose “Run as Administrator”, then type in

set INITDEBUG=1 yourinstaller.exe > debug.txtand then run the installer again? That should generate a text file with some information about the installer that we can use to figure out what’s going on. After you’ve gone through the process, just search for “debug.txt” on your machine and send that to support AT literatureandlatte DOT com or upload it here as an attachment (you’ll need to compress it to a zip file first before uploading).

Unfortunately, it doesn’t help.
The file I downloaded must be OK, because I used it on the other laptops.
But I tried anyway, cleared the cache, downloaded again, same error.

There is no such thing as Run as Administrator when I right click…

When I try to enter what you said it says I get

Scrivener-049-installer.exe is not recognized as an internal command, operable program or batch file.

I also tried “yourinstaller.exe”, just in case this is what you meant, but unfortunately, same error message.
I tried all kinds of variations, including “CODE:SELECT ALL”, etc.
Nothing works.

Sorry for being such a klotz.

No no, my fault, I didn’t put in the actual installer name and that was very unclear. Although it sounds like you weren’t in the command prompt anyway, due to my poor instructions. Let me try again, this time with a helpful resource which will give you some images.

  1. In the Windows start menu run field–the area at the bottom where you can type–type “cmd”
  2. Then type Ctrl-Shift-Enter to launch the command prompt in Admin mode directly from there or right-click the “cmd.exe” file that should appear in the search results list in the menu as you type (listed under “Programs”) and choose “Run as administrator” from there
  3. Once the command prompt opens, which will be a new window, in that window type

set INITDEBUG=1 Scrivener-049-installer.exe > debug.txt
(That’s the actual name of the installer, so just use that text exactly.)

Then go ahead and follow the rest of the directions, running the installer and then sending the .txt file afterward.

Thank you.

I did what you just said and it generated a debug.txt file in the system32 folder that is completely empty.

Yesterday when I tried it generated another empty debug.txt file in my C:\Users\Myname folder.

I did a google search on similar installation problems and people say it has something to do with the (x86) string. I am just repeating what I read.

.
It 's a miracle :open_mouth:

I tried the installer again and it worked!
I think what happened was that I started the installer from a different shortcut of the Download folder…

I have no idea why, anyway it is working.

Thank you very much for trying to help me. :slight_smile:

I’m delighted that it’s working, although it’s most mysterious. If you have a chance, could you tell me exactly where you were originally trying to run the installer from (maybe I should say how you were trying to run it) and what you did differently this last time? It might help out other users with this issue, and it might even be something we can address in code or speak to the installer company about.

I wish I could tell you what happened. When I bought this laptop I have changed the location of a few folders and renamed them to make sure I can find them easily.
I have moved the Downloads folder from the Documents folder into my User account and renamed it My Downloads.

When I tried to install Scrivener, I noticed that the path it said was different from what I had, but as I never had problems installing anything else, I dismissed the problem.
Before I succeeded installing Scrivener, I was looking for the My Downloads folder and was surprised when it was gone and somehow was put back into the Documents folder… Or maybe I just used the shortcut on my desktop I never use normally… Anyway, when I started the download from there, suddenly it worked.

I know it is confusing, but if I were you I would not worry about it. It must have been a special case as nobody else was having my problem.

Sorry for not being able to help you more.

Looking forward to downloading the final version and start writing that bestseller :slight_smile:

Ah, thanks for the explanation. It most likely is a case of the changed shortcuts/locations etc. Windows can get very finicky about you moving around the special folders it’s set up for you, so chances are somewhere en route the file path just got mis-delivered and the full installer couldn’t be found. Anyhow, glad everything’s up and running!