Problems saving projects

I have recently re-Installed Scrivener after replacing my Hard Drive.

Since then, it refuses to save my projects, dumping changes to a recovery file and closing the projects.

A new test project seemed to save ok - until I imported one of the real projects into it: then I had the same problem.

I have tried rebuilding the indexes, but that made no difference.

Any suggestions welcome. I have used Scrivener prior to my HD replacement without any problems; and have two projects on the go which I really need to make progress with. But I can’t work on either as they are shut down within minutes of my opening them!

This sounds like permission issues, common when migrating to new hardware. The only odd thing about it is that the problem seems to persist after importing one project into a blank one. But we can at least try the fix for permissions and see if that solves it.

The trick with Scrivener files in particular is that you are really only looking at the top level folder. There are bunches of files hidden underneath the “file.scriv” part, in what we refer to as a “package”, that may still have the wrong permissions applied, and since Apple’s Finder cannot recursively fix files inside of a package in the same way that it can with a folder, we just need to trick Finder into doing so.

  1. Select the Scrivener project in the Finder that you need to fix.
  2. Use the File/Get Info menu command with it selected.
  3. Expand the “Name & Extension” section if necessary, and change the name so that the “.scriv” is completely removed. The icon will become a normal folder a moment after doing so; this is quite okay, it is what we want.
  4. Expand the “Sharing & Permissions” section if necessary and click the lock icon in the lower-right if the icon is in the locked position. You may be asked to type in your password.
  5. Set the “yourname (Me)” row to something other than Read & Write.
  6. I know, seems dumb, but now set it back to Read & Write—we just needed to do that to activate an ability for the next step.
  7. Use the gear menu to “Apply to enclosed items…” and confirm the warning message.
  8. Go back to the “Name & Extension” section and add “.scriv” to the end of the name.

After a moment it should turn back into a Scrivener icon and you should be good to go.

Thanks Amber, that seems to have sorted it. Great that Scrivener support is as good as the product (and that’s saying a lot!) :smiley:

So that worked - but a new problem has arisen. Scrivener won’t allow me to close the project, or quit Scrivener. I have re-booted, and that did not fix it. In fact, it seemed to cause new problems with the permissions, which I had to re-set again, as described above.

Any suggestions as to what I might try next?

(This is not as urgent as previous request, as I can now use Scrivener - but I would like to sort it!)

Thanks.

What do you mean, in terms of error messages or other symptoms, by not being allowed to close a project?