Problems using services menu to Scrivener

I can’t get highlighted text to paste into SC using the Services menu on Safari.

I just upgraded to Safari 5.0.1, so perhaps that is the source of the problem.

Highlight text
Use service menu to select with new clipping or append.
Since I have scrivener in a different space than Safari I see the space change from the safari to SC but no text is added.

Any suggestions as to the possible cause of the problem?


I’m not sure what you mean by this, but it almost sounds like you are describing what happens when white text is imported from Safari. Since its format is retained, the text will remain white, but being on a white background in Scrivener, will appear as though nothing is added, though a space change will occur. This might be what you are describing.

A simple check is to press Cmd-A in Scrivener and see if anything pops up.

Apologies for the poor description of the symptoms.

  1. First regarding your suggestion I did look at the location where I expected the text to be posted and tried the select all but there is no additional text in the entry.
  2. Regarding my description. I’m using “Spaces” under 10.5.8. I have safari displaying in space #2 and SC displaying in space #4. When I go through the motions of selecting and sending the text through the services menu my display changes from space #2 (Safari is the application in focus) to space #4( where SC is the application in focus), but no text is added to the entry in focus, nor is a clipping added.


Spaces! Yes, now I completely follow what you are describing.

I seem to be able to replicate this problem as well. The Service is available in both right-click contextual and Safari/Services menus, but when I choose any of the available Scrivener services, nothing seems to happen.

My first reflex, whenever encountering a bug with something Apple provides, is to test the results with another application. TextEdit is a good testbed for weirdness, because it is just a very basic implementation of the same system many other Cocoa applications use, such as Scrivener. So I enabled the “Create new document in TextEdit with selected text” Service, and again tried with some selected text from Safari, and bingo nothing happens.

This very likely is an Apple bug with how the new Safari communicates with Services. I tried from some other programs, and it worked fine for me. Just Safari screws up. Do you get the same results?

As an aside how do you get “services” in the contextual menu? Are you using the “add on” from Devon?


  1. I found a partial source of the problem, perhaps you understand the source? I had two SC documents open. One was in the Dock and the other was open in the space and intended to be the focus of the work. It turns out that the services menu was sending the highlighted text to the document in the Dock. Since the item in the Dock is not in focus I don’t know if this is a bug with SC or perhaps there is some other source of the problem?
  2. Regarding going from Safari to TextEdit I have the following result. I select text in Safari and use the services menu for TextEdit to “New Window Containing Selection”. This seems to work as expected.

Snow Leopard puts the a copy of the Services menu into the contextual menu in certain relevant conditions. If you are still on Leopard that would be why you can’t see it. If you are on SL, then I’m not sure why you aren’t getting it.

On further inspection, I think part of my problem is that I have a huge mess of Scrivener copies on my system. :slight_smile: Since we are alpha testing the new version, my Services are all confused over which one to use, so I think what I was seeing earlier might have been related to that. I temporarily removed all extra copies of Scrivener, leaving only 1.54, and was able to use Safari to clip text to Scrivener projects. I wasn’t able to replicate your condition where a docked project ended up getting everything even though the other was the last active project. If I leave one test project minimised in the Dock and another out open, the open one gets the text.

I tried turning on Spaces and recreating your described situation as closely as I could, and everything still worked fine. Even more curiously, TextEdit works as well. I have a feeling that my Services system is a mess. I never ever use it, so it could be totally corrupted and I wouldn’t have a clue. Sorry I’m not being much assistance here! :slight_smile:

Can you reliably reproduce your condition starting from scratch? If you can get me a set of steps, going from Scrivener start-up, which projects are loaded, the order they are minimised, moved to other Spaces, etc—every detail, and come up with a case that reproduces, that would help.

First thanks for your help and the time you’ve invested looking at this for me.

I’ll make a fresh start tomorrow and report back on what happens.