Problems with Compile - can't compile subset of documents

I am running version Version: (1905013) 64-bit - 19 Jan 2023 on a Windows 10 Home ver. 22H2 laptop

When I am in Compile and select a subset of chapters/scenes to compile as a manuscript in RTF or ODT format, the entire manuscript is compiled, and not the selected files.

Is this is a known issue? New? Any thoughts?

Works fine for me.

Either select all the desired documents in the binder (subdocuments and all) and compile current selection.
Select only the parent, and check include subdocuments.

Check that the funnel isn’t blue… image

Does the compile list match your intent ?

Say this still doesn’t work, can you provide a screenshot of your compile panel, set as you just failed to compile only your selected files ?

Thanks, That’s what I do… here is the screenshot

You are not compiling your selection.
You are compiling the manuscript indeed.


And you have the filter turned on. image

Set your compile scope to “current selection”:
Way more convenient. And you won’t have to mess around with the “included in compile” state of your documents.
Just select the documents to compile in the binder and that’s it. Compile.

And, of course, turn off the filter.
It is likely currently set to include all.

thank you. 2 things.

  1. I don’t have any filters set.
  2. When I select Current Selection, only one file shows up from my selected subset.
  3. all the documents are selected to be included in compile.

You do. image

This file is neither a folder or a file group parent.
There is no other file(s) inside it (in the binder). In other words, there are no subdocuments to add to the list of documents to be compiled.

Apply Filter is NOT selected. Therefore, no filter should be applied.

Click on the funnel and take a screenshot please.

It will say “Compile: all”.
You want it to “Compile: Included documents”.

Now you turned it off. (I can tell by whether the funnel is blue or not.)

Fix your binder structure so that “On the Trail” is parent to the other files you want as subdocuments, and you should be good to go.

If you don’t want them inside that “On the Trail” file in your binder, no problem, just select all the documents to compile in your binder and that’s it. Uncheck “Include subdocuments” and compile.

Make sure your documents are properly set to be included in compile. Changing this status by checking/unchecking them in the “to compile” file list affects their status in the whole project.
If you used that previously to control what would compile or not, you might have messed it up a little.
That is why (among other things) it is much better to compile only the selection when doing partials.

On the Trail is not the parent. It it a scene. The Chapter is “Quest”.


So we agree. If it has no subdocuments, the “include subdocuments” option in compile has nothing to add to the list of compiled files…

Select all the files to compile in your binder then compile with the subdocuments option unchecked.
(If you have no parent files/folders in your selection you can leave it, but in the case you do, and don’t want all nested files to compile as well, uncheck it.)

And when things go sideways, the first thing to check is that famous funnel.

I figured it out.

I had to select the chapter from Manuscript.

That worked

Indeed, that is another way to go about it.
The downside is that if you only want some of the files inside a container, you’d have to uncheck the ones you don’t want, and that affects their “include in compile” state in the project.
It doesn’t revert after the compile operation.
The file(s) will remain excluded until tweaked otherwise.
I never use that method of what to compile selection. (Personal preference.)

P.S. I have no clue as of to why you have the filter back on. But at this point if you get the result you want…

Thanks for your help