problems with compile


First, thanks for a great product!

Got introduced to it through the trial version of NaNoWriMo and just purchased and installed 2.02 without a hitch today. Except for one problem, with compile, which I first noticed in the final days of the NaNoWriMo version. It’s persisted in the new version.

It’s a problem with the compile settings, which suddenly won’t allow a file to be exported in rtf format. All that works is creating a pdf file, getting set to print, and then saving it.

It’s not exactly a crash (which I know is addressed on the “bug” forum, and where a posted initially.)
It’s just that the apparent rtf/word compatible files that seemed to be created by compile no longer open.

I’ve checked for updates and the message I get back says I have the most current version of 2.02.

Any suggestions?

Thanks again!

When you say it won’t open, what exactly happens? From the sound of it, the RTF file is being produced, but just won’t open, is that correct? In which program are you trying to open it, and what message do you receive?


Thanks for the quick reply!

I discovered that the files can be opened, but only through text edit. My usual word processing program is Microsoft Word.

Are you opening Word and then opening the .rtf files through the menu there, or are you just double-clicking the files via Finder? They may not be opening in Word if TextEdit is set to open .rtf by default, but they should certainly be compatible with Word.

I had been just double clicking on the files (which had worked as recently as Dec 1 with the the NaNoWriMo trial version of Scrivener,then something changed.)

I did try opening through Word and I can’t figure out how to do it. It’s like it doesn’t recognize them as word files.

Okay, I did figure out a way to open in Word.

First, I had to open the Word program. Then, in the desktop folder in which the documents are stored, I had to change the setting to “enable all documents.” Only then I could I open the final Scrivener-created rtf files.

It’s just a little cumbersome to have to take this extra step. Also odd that I don’t have to do it for my Scrivener documents compiled/exported through late Nov. (I backed up regularly throughout the month.) For those earlier rtf/word files, I can just double click to open. Something changed, somehow. This stuff baffles me :slight_smile:

You can right click on the file, go to the “open with” option then select “Word” from the submenu. That will open word for you automatically.

Alternatively you can reassign word as the default RTF editor but

Right click on the rtf doc, select info, in the new info window set “opens with” to word, select the “change all” button to apply system wide. Close the window and double click on the rtf file. Should open word automatically.

This baffles me, too, because I’ve never heard of this being necessary! :slight_smile: What do you mean about having to choose “Enable all files”? Where did you do this?