Problems with download

I’m having problems installing the trial version of Scrivener (1.11).

The download appears to go okay, but when I click ‘Agree’ on the license page, the volume doesn’t mount (and Mac OS says ‘verification failed’).

If I go to the DMG file, and try the same thing, I get a warning saying ‘codec overrun’.

I’ve tried this on two different machines - one a G5 (PowerPC), the other a new MacBook (Intel), both of which are running Leopard (10.5.1), and both give me the same error. I have admin privileges on both machines, and I’ve also tried repairing permissions and rebooting several times.

Is it possible there’s a problem with the DMG file as posted on the website? If not, any other suggestions on what might be causing this?

There seem to have been a lot of problems with this over the past few days. I think it is a server problem, whereby the file is getting corrupted on download (I doubt it is a problem with the DMG itself, as hundreds of new users have installed successfully - I think; I will check). However, after Christmas I will look into this.
Best,
Keith