Problems with local keyboard after upgrading to Leopard

Hello,

I started having problems with Slovak QWERTY keyboard after upgrading to Mac OS 10.5.2. Everything worked fine in Tiger. After upgrading, dead keys stopped working (dead keys are those, that are just prefix, which signify if next letter contains some accent). For example by typing (as seen on US keyboard) 'a (that is apostrophe character and a), it should write á. The same goes with +c, which should write č.

Writing of these characters works correctly in all other applications, so I suppose it's some kind of misunderstanding between Leopard and Scrivener. When I type 'a, I get literally 'a in Scrivener.

 You can try it by configuring Slovak QWERTY keyboard (it's easy to switch between US and Slovak keyboard, I use US keyboard primarily) and trying to type 'a.

 Seems too bad for me, since I can't easily downgrade and I am trying to finish my thesis in Scrivener :frowning:.


    Juraj.

Sorry, it’s apostrophe accent, but it’s on the same key as “=” on US keyboard. And I noticed some characters (such as +d, which produces ď) work and some others (such as mentioned ó or á, which can be typed by pressing =o, =a on US keyboard) don’t.

Sorry for confusion, I hope it could be well understood now…

Sorry, I’m still a little confused. Please take pity on me and bear in mind that I’m English and as such have little in the way of a second language, so I rarely have to use any accented characters other than an accented e (such as in café). Could you please just give me the basic steps to reproduce this using US keyboard layout (I think the British keyboard is pretty much the same to the US one on Macs)?

Given that you mention apostrophes, could this be anything to do with the smart quotes feature? Try going to Preferences > Typography and turning off typographer’s quotes.

Thanks,
Keith

Hello,

turning off typographer’s quotes solved the problem. Anyways, here are steps to reproduce (in
case you wanted to look further into this problem, as accent dead key should in no way be treated
as a quote):

System preferences, International, choose tab Input Menu, click on checkbox left to
Slovak - QWERTY (so you add this to your default keyboard). Make sure you have
“Show input menu in menu bar” checkbox turned on, so you are not lost with slovak
keyboard and can switch keyboards with your mouse (by clicking on flag on the
“menu row” on OS X).

Go to scrivener and type =o

It should show ó, while it in fact shows 'o (two characters).

Anyways, thanks for helping, I don’t use typographer’s quotes anyway.