Problems with reference files and image tag (scrivener 2)

Hi everyone,
I have some problems with the use of image tags. Having quite some images in my thesis I would like to avoid putting everything in the binder, so I am using the tags to reference an external file in my HD. Everything should work fine but after the compiling, I do not have any image at all in my PDF.
The grammar I am following is this one:

<$Img:/path/to/image/image.png> for linking

Figure <$n:figure:image> for referring

I tried also making the image smaller with <$Img:/path/to/image/image.png;;w=200> but nothing changed.

Is there any option in “Compile” that I should check?

I have to say that at the beginning everything worked fine, but then I converted the project to Scrivener 3, and then again I save it for using Scrivener 2 (the whole papers 3 problem. Gonna enjoy scrivener 3 after the thesis). I do not know if it is relevant or not, but maybe it caused some issue.

Anyone have any clues on what can I do to resolve the issue?

p.s. If I create another scrivener project, the same exact image tags work flawlessly. I would, however, prefer (in case it is possible to fix the issue of course) to avoid remaking the binder structure/notes etc for the thesis

Yikes, sounds strange. What if you copy and paste (retain formatting) the <$img:path> from the affected project to the new project, does the image then fail to work (i.e. is it something in the RTF text itself or a setting in the project)? Have you tried rewriting the <$img:path> placeholders from scratch in the affected project just in case they somehow corrupted (can’t see how it is plain text after all)…

Could you possibly make a copy of the project and strip down the project so that it shows the problem for a single image, then post it here (zipped up)? You can delete out the text or just use some dummy text so that you aren’t posting anything you don’t want others to see, just a project with an image tag that doesn’t work.


Sorry for the huge delay but I didn’t had a second lately. Thank you for your answer, here …
it is a zipped copy of the project stripped down to everything. The only thing to change is the path of the images, which currently point to a folder in my HD.

In a new project they work. Simply copy - paste and everything is fine. An alternative solution is to copy everything into a new project, but it seems quite some work to remade the structure I have in the binder, with the attachments etc.