problems with spacing in screenplay formaat

I’ve spent six hours trying to make a custum template, but keep having trouble with the spacing between elements.
I start with the standard screenplay format where the spacing is perfect, but when I change the indents for scene headings and action and click on ok and then go to write in the document the spacings have been changed. When I go back to script formatting window you can see that spacing has spontaniously set itself to 0. Even when I insert the spacing distance myself, the same thing happens again after I click ok.

This is driving me a little insane. Does anyone have any suggestions?

Try to set your default text style.

Option(F12) / editor

Set your favorite font, spacing, etc…

Save your choise (Manage / save preference) and apply.

This is for new document.
To older, select them and do this:
Documents /Convert /formatting to Default Text Style

Than you for your reply. I tried this but still, the moment I click on action in the document, for example, the above allocated spacing vanishes forcing the text right up under the scene heading.

When I start with the basic screenplay template everything works. It’s only after I have changed the indents in the format window that this problem starts to happen. For some reason the format window refuses to hold onto the spacing above info :frowning:

Add on:
This s now my thitd day trying to solve this.
No matter what I do, the scripwriting format window will NOT remember the changed spacing values.