Problems with Styles

Hi. I thought at first that I was doing something wrong. Turns out I wasn’t.

I am attempting to use styles on a project. For a little while it worked great. I could click on heading 1 or heading 2, or even text and list, and styles would fix it how I wanted it. Then it stopped changing the font when I clicked. Then it started changing it to default color (black), with a tab indent, and the wrong size. I can usually manually reset it to what I’m looking for. (copperplate gothic 11 for heading 2, same in 12 & bold for heading1, Century Schoolbook 11 for text.

Now I have parts that I can’t change using styles or using paragraph–line spacing (5 or 10 points below and single spacing). I’ve tried every way, about 2 dozen times. one line at a time, two lines, all lines. No change in line spacing. The good news is the font still works.

Does anyone have any ideas? I’m supposed to publish at the end of the month, and I don’t have another program to make these changes with. Help?

Thank you! Sorry to be a pain.


Hi Kim.

First off: you are not a pain.
Now, with this set straight :wink: :

There is an issue with the Windows version when using styles set to have next style as “self”, where it will rather use the default formatting, even though the style is otherwise properly assigned to the paragraph.
(First paragraph would be fine, then you hit enter, new paragraph is of the right style, but the font is wrong.)


Everything in your description matches that, except for the indent. The indent is usually the one set in the style, despite the rest.

Could that be what you are experiencing ?

If so, the solution is to (unfortunately) change the style to another one and back when it happens.
(If that turns out to be your issue, I’d recommend that you create a dummy style (name it so it is first in the list and easy to find – “000 Dummy” or something) and set that style not to include font family and font size. Also make it paragraph formatting only.
This way it won’t mess anything up, if your concerned paragraph contains highlights, italics etc, and/or your actual desired style doesn’t specify font and/or font size.

I will give that a go. And I’ll let you know how that works out.

Thank you.
Be well!

Okay, well, the style without the font worked. The font still isn’t working on its own. It is also still going from white font color to black. I’ll keep playing around and see what I can do.

Thank you again.

By “white” you mean the default color?


Is your Scrivener themed ?

So, ah, apparently I lied when I said some things were working. I end up retrying many of the steps we talkd about, or just re-selecting the style or doing it by hand in the hopes that somehow it will work. Eventually I’m about 75% successful. It takes me about an hour of that to get something to work out. There are places where it just won’t cooperate. The only part that regularly does not cooperate is the line spacing I use before or after text or headings. I am just sticking an extra line in and hoping that it doesn’t look bad. I might for consistency I might have to delete all the line spacing info, put it on single spacing and use multiple lines @ different font size to rig the thing.

Looking forward to any further help, but I’m fairly resigned to my fate. This was more an update than a plea.


This is neither a or the solution.
You are only setting yourself up for future problems.

I’m not doing anything drastic until it’s time to publish. It’ll only be a last minute action to get things spaced well. Until then I’m open to any suggestion and will give it a try. I guess I’m just quite discouraged.