Problems with tabs when importing form Word

I’m attempting to import a Word file into Scrivener, but I’m having some formatting issues I can’t resolve. Specifially, my normal .5" tabs are suddenly 1.25" wide, and changing the formatting within Scrivener doesn’t seem to help. I’ve also tried importing the file as .rtf and simply copy/pasting them from an open window, but the issue is the same. Would appreciate any advice!

One quick question that might side-step the issue: can you use the Documents/Convert/Formatting to Default Text Style menu command with acceptable results in your imported work? This command will convert the original base formatting to your Scrivener defaults (matching any new documents you create in the future), and cleaning up any abnormalities in the process. It’s pretty good about passing local changes through, like italic ranges, and can be tuned further to respect types of formatting you do not wish to lose.

Thanks for your help! I tried doing different things with that option, and none of it seemed to help.

A few screenshots might help then. Show something in Word with the ruler visible, and then in Scrivener after importing, again with the ruler.

Do you use the actual Tab key in Word to insert your indents, or are they automatic indents by adjusting the first-line indent marker on the ruler? It sounds like you may have been using the tab key and that the tab is now being added to an auto-indent. (The ruler settings for an imported document should normally come with the document, but depending on the format you used this might not be happening properly). If you turn on Format > Options > Show Invisibles in Scrivener, do you see a little blue arrow at the beginning of each line? (Having that on for the screenshots would be a help, too.)

I’m new to Scrivener and I’m having this problem.

I was using tabs in Word, but only part of my document in Scrivener has the extra-wide tabs. (I cut and pasted into Notepad, then again into Scrivener.)

When I turned on “Show Invisibles”, those extra-wide tabs did have a blue arrow in them (the right-sized ones didn’t). How do I convert those sections to the normal type of tab?


Tabs, the ones that show up as a blue arrow, are actual characters in your document. They are just as much a character as the letter ‘a’. It’s just that most software, when confronted with the tab character, chooses to display it as about 4 to 8 spaces. When you turn on invisibles, you are telling Scrivener to draw that character using an arrow instead of spaces.

So it follows that it can be searched for and replaced just like any other character. The only trick is that hitting TAB on your keyboard tends to be used to move around in the interface. So if you try it in the Find window, you’ll just end up in the Replace field. What you need to do is select the tab. Put your insertion caret to the right of it, then Shift-LeftArrow to select the space. Use Edit/Copy, then in the Find window, right-click and Paste. (Ctrl-C and Ctrl-V are okay as well if you prefer).

Leave the “Replace” blank, so that tabs will be replaced with nothing, and replace all. Do this for each document that has arrows in front of paragraphs, taking care to avoid any sections that use tabs legitimately for tabular data input!

Thank you very much, AmberV.

I still had to go through and make sure that there was a paragraph mark at the end of each paragraph so the indents would function properly, but it was a shirt piece, so it didn’t take too long.

While I have you, is there any way to modify the ongoing word/character count at the bottom of the main window to reflect all documents inside a certain level (chapter or whole project)? I write in scenes, but those word counts are less useful for me.

I know I can get the count from a pop-up window, but I’d love it displayed all the time. Alternatively, can I lock that window somewhere and have it count in real time?

Thanks again!

Scrivenings mode is best for that. What I do myself is make use of the View/Go To/Enclosing Group command, which you’ll note is bound to the easily accessible Shift-Alt-UpArrow. What this does is basically navigate “up” in the hierarchy. Kind of like in Windows Explorer and you are in your Documents folder, you can press Alt-UpArrow and you will end up in your user folder, where Documents, Downloads, Desktop and other folders reside. It’s the same idea. Your scene is in a group with other scenes, forming a chapter. If you press Shift-Alt-UpArrow, you’ll end up looking at the whole chapter on account of how Scrivener shows you groups of things. So just switch to Scrivenings view at that point, by pressing Ctrl-1. That will give you the count for every document in the chapter (and incidentally you can work in that whole chapter as though it were one text file, too. That’s what makes this mode great). If you want to isolate the scene and just work on it again though, Shift-Alt-DownArrow will do the trick.

Thank you, AmberV! You rock!