Problems with titles by compiling

I try to get into this program but have problems by compiling. Despite giving the chapters names on the list (left) after comiling it gives me a title: CHAPTER EINS followed by the chapters name. I would like that mix of English + German “Chapter Eins” not shown. Is this possible?

Another problem I have with exporting.
I intend to create a document with partly Chinese and some Korean characters in it. After exporting insted these I just get some squares. How can I fix that problem?
Would be thankful for your help!

You’ll find instructions for altering the appearance of the compiled output in §23.8 of the user manual (pg. 328). Specifically in regards to the modification of title embellishments, such as the “Chapter Number” bit, see the sub-section on Level Settings, starting on page 333. This is all of course entirely customisable. You can even make folders at one level of the outline do one thing, and nested folders beneath them do another.

While learning about the Formatting pane in that section and setting up the title appearance, be sure to select an output font for the headers that is appropriate and contains the characters you are trying to use. The Mac comes with a number of fonts with Eastern script characters, some also have a decent appearance for Roman characters as well, so work good for combinations.

As someone who regularly uses a mixture of English and Chinese, but without problems, can I ask: (1) what font you are compiling in; and (2) what app/program you are opening the resulting file in?

It all comes down to the fact that Macs and Scrivener use UTF8, which means that the fonts in general also include the code areas for CKJ scripts. Using Scrivener, or a word-processor like Nisus Writer Pro, if your text font is Lucida Grande, Helvetica or Arial, the Chinese will come out in STHeiti styled characters; if you use Times New Roman or Times, the Chinese comes out in STSong.

So, in terms of (1), while AmberV is right that fonts like STHeiti and STSong also have the glyphs for Roman script, there are two problems with them: (a) I would disagree with their having a “decent appearance” … they tend to be badly kerned, and, in particular, the Roman glyphs in STSong are horrible — e.g. an upright script “a” in a generally somewhat “Times-alike” font — and (b) more importantly, those fonts use the punctuation from the Chinese code area, where they are given the space required for a Chinese character — depending on what system you use to enter your Chinese, you may be able to switch full-width punctuation and space off, but you will need to switch them back on for the Chinese — and the results look totally wrong — e.g. an apostrophe followed by a long white space. This last, punctuation problem, is something I’ve had to battle with every time for the last 7 years when stuff I’ve edited has been typeset on a Chinese system.

On (2) depending on the program you’re opening the compiled file in, it may be that that is expecting GB2312, GB18030, Big 5, or any of the other coding systems. That gives bizarre results or empty squares.

What happens with Korean, I can’t say, as I don’t know Korean and have no experience of entry systems or fonts.

Incidentally, if you’re not doing so already, for your Chinese input, I would recommend IMKQIM + QIT in preference to the Apple system any day. It is now free, I believe.

Do get back to me if I can be of any more help.


thank you a lot! I was looking at this button on the menu and simply overseeing it for quite a time. Managed it now and it works perfect.
thank you for your long answer. I’m not as advanced. I just got the wiriting tools for Asian from the mac system itself as I installed it. This was probably under Leopard at the time and upgraded it by Snowleopard now to Lion. I can transfer by copy and paste from my previous word document. I can also type in to the Scrivener quite normally. But bringing my file back into word fails to show up the character properly. Thought they all use the UTF8, but I’m not sure.
By the way: after compiling the character stays intact. I use times at the moment. I also played around a little with different fonts. STHeiti and Lucida Grande got same result, converted to MS … in .docx with the loss of the character.
So I got a little helpless with my problem as I have to add the character for specification in to the script.
The Korean I actually did not try as this part is still on my actual word document.

If you’re going to be doing much input in Chinese, I’d definitely take a look at IMKQIM … it’s much more flexible and powerful: you can switch things like punctuation and spacing; you can work in both Simplified and Traditional without having to switch input mechanism; you can customise the input list; and by installing QIT it remembers sequences of characters you have typed so that they come up at the head of the input list building your own dictionary, and saving a lot of effort.

Which version of Word are you using? I have to say that I am a virtually Microsoft-free zone — Skype, now it’s owned by MS, and MSN are my only contact points — so I have no experience of recent versions. On the other hand I have been continually exchanging documents with users of Word (Chinese version, mostly using computers running Chinese Windows XP) for many years. Most of the time there are no problems, but some are thrown up occasionally. MS uses its own text-engine and some systems still use GB18030. But if it’s a recent version of Word on your own Mac, then there shouldn’t really be a problem … mind you, of course, Word’s ability to be incompatible even with the file formats of different versions of Word is legendary!

Hang on … it would help here if you said exactly what your work-flow is:
(i) Have you imported the Chinese text as part of (a) document(s) previously created in Word, or entered them in Scrivener?
(ii) “… after compiling the character stays intact” … How do you know this? What format are you compiling to — .rtf, .doc, .docx? What app are you opening it in to know it’s “intact”?
(iii) “… converted to MS … in .docx with the loss of the character” … this sounds as if you are compiling to something else and opening that in a recent version of Word using .docx.
(iv) Which version of Scrivener are you using? Look at “About Scrivener” in the Scrivener menu. Not just which version, but also tell us the build number which is given there. The most recent build is 17148. Keith recently introduced a new set of libraries enabling direct compile to .doc and .docx, giving very much better results, but to run those you also need to have Java installed — from the change notes:

(v) Another question which might be of help; from your other problem with chapter names, I assume your system is German, with a German keyboard layout. Am I correct? I don’t see how that could affect the Chinese, but from the Nisus forum I know that there can be issues at system and font level resulting from the different key assignments.

Generally, the more information you can give about your system and your work-flow, the easier it is to track down these things. Also, at some point, if we are not getting there, you could make a .zip copy of your project and send it to for them to take a look at; if it would help they could send it on to me too.
Also, if you have not been doing that, try compiling to .rtf and opening that in Word. Are the characters still preserved then.
Keep your courage up, Eva. These issues can be solved I’m sure. I’ve been working for years in China, editing and writing texts in mixed English and Chinese which I have been passing to Chinese colleagues and students using Chinese Windows and Word, with few problems — the last problem I had was importing files in .doc format containing images which turned into Hex code. I always compile to .rtf and there has never been any problem.