Program freezes temporarily whenviewing PDF[BUG LOGGED]

My apologies if this has been mentioned by someone already. I looked and didn’t see.

This has already happened a few times. This time I tried to make it happen.

Here’s what I did:

  1. Opened project where I have a PDF saved in Research
  2. Split editor vertically, with the PDF on the left and a document from Draft on the right
  3. Tried to scroll down in the PDF

The program stopped responding for several seconds before starting to work again. Same thing happened the next few times I tried to scroll down through the PDF. One time the entire program went light grey. I came here immediately to record it.

Just went back to work and it now it seems to work as it should.

Aaaaaaaannnd now it’s doing it again. The problem seems to be worst within the first few moment the program is running. I love the idea of this feature, but it’s so unreliable and slow right now that I have to open my research PDF in a separate window to actually get any work done.

How big is the PDF file?

Could you send me the file: lee AT literatureandlatte DOT com

The file is 1,397 KB. Is there a maximum size that I missed?

I’ll send it along. Thanks!

I had a similar problem. If the PDF is too large, it won’t even open it or Scrivener freezes until I get rid of it. This was a usual problem in Scrivener for Mac (at least version 1), so I wasn’t really surprised.

I also found out that there is a different behaviour with PDFs. Some are viewed perfectly on Scrivener, but others may appear as blank pages, or with distorted images. Here’s an example: http://blog.apastyle.org/files/how-to-cite-something-you-found-on-a-website-in-apa-style—table.pdf

This is a single page PDF, with no graphics; except for the fact it is a table in landscape arrange (horizontal page).

When I import it to Scrivener, it appears blank. I also tried to import it as a website, but all I get is funny code.

Okay, thanks for this. There are a few things we can do to optimize the code for the PDF so that will be the first thing we will try. I have logged a bug.

On my machine I only notice this when I have a PDF over 15MB running quad core i7; however, the Windows XP machine I’m running with 1GB and 1.6MHz chokes for at least 90 seconds trying to load the file.