Project and Session Targets

Hi,

I can’t figure out how to set project and session targets. If I go to View/Statistics/Project Targets, I can only set the Project target. If I set it to 100,000 and close the application, when I open it again, it is set at 100. There is no place on this dialog to set the session target.

I’m sure it’s just newbie disorder, but please help.

thanks,
debby

Update: I opened a new project, and it worked properly at first. But in this case, I defined a target for a document before I even opened the Project Targets dialog. When I reopened the old project, it was still misbehaving. When I closed and opened the new one, it started having the same problems.

debbym,

It appears that you should not type the comma in the number when you type in the project target.

The session target number (which will be showing zero right now) is editable, too, you just have to click on it.

–greg

p.s. You might want to review the following thread: [url]https://forum.literatureandlatte.com/t/sluggish-statistics/1480/1]. There may be some issues with the new project statistics functionality. I haven’t encountered any myself, though.

I didn’t see anything to distinquish it, so I assumed it wasn’t there.

I tried your suggestion about the comma, and it didn’t change anything. I have saved one of the offending projects for the developer to look at, if he wants to.

Thanks for the pointer to the forum discussion.

I’m not sure I understand the issue. Click into the target word count text field. It may not look like you can click into it (so that it isn’t distracting), but you can. Once you have changed it, hit enter. Does that solve your issues?

Hey Keith,

Here’s my experience with the target. Open a new doc, and you see the target you’ve entered on the little progress bar. Click the target icon, and the progress bar shots up to full, and stays there till the next time you open the doc.

Hope this helps, Keith.

  1. T

I literally have no idea what you’re talking about. Sorry. I really need a decent description with steps to reproduce.
Thanks,
Keith

Sorry for being cryptic, Keith. Here’s what I hope is a more cogent description.

  1. Click target icon in lower right of document
  2. Enter target number (eg, 6000)
  3. Click ok
  4. Progress bar in lower right shows reasonable approximation of actual words compared to target
  5. Click target icon again.
  6. Progress bar instantly fills to indicate target complete
  7. Target entry window has lopped of last three digits (eg 6000 has become 6)
  8. This remains the case until closing document and re-opening it again.

Hope this helps,

Tim

Scrivener seems to only read the figures before a comma in either of the fields. E.g. if you enter “50,000” in the project target field, it thinks your target is actually 50 and fills the progress bar accordingly.

Unfortunately, you can’t get round this just by typing “50000” into the field, because Scrivener automatically enters a comma into the amount when you click away from the field. So even typing “50000” results in a target of “50,000” and the consequent problem behaviour.

(Hello, by the way. New user, love it, just started my next novel in it :slight_smile: )

Curses, that’ll teach me to spend ten minutes signing up :wink:

I really cannot reproduce this. Weird.

Perhaps its a powerPC issue?

T

I can duplicate what Tim is reporting on a dual G4 10.4.9.

However, I notice that if you click again on the target button a comma is displayed. If you reenter the number without the comma and close things seem to be correct.

Dave

I’ve just tried this, and following Tim’s steps above causes the same problem. (Not something I tried independently, so I can’t say it’s causing me trouble!) Running 10.4.9 on an iBook (700 MHz PowerPC G3). Using the menu or keyboard shortcut to re-view the target doesn’t cause the problem.

However, I suspect it might be something to do with the comma in the format. Even though the comma is generated automatically, it is still interpreted as user input when you press OK for a second time (it’s interpreted as a decimal point, by the looks of it). This strips off the trailing 000 after the comma, causing the word count target to drop to something in single or double digits (for example, 3,000 drops to 3; 3,000,000 drops to 3 as well). Because the document probably has more than 3 words in it, otherwise I wouldn’t be playing with this feature, the app reckons I’ve achieved my target and displays a nice full status bar. According to my no-doubt mistaken theory, the reason it doesn’t happen with the menu or keyboard shortcut is because there is no “OK” reset option there; you just have a look at it, then close the window (or edit the field if you want to, but that would be a deliberate change that you’d know about) – but closing the target box (from the little bull’s eye symbol) with the OK button effectively says you’re re-entering the data. For me, the revised target persists; it isn’t reset on closing the document.

So, I’m no expert by any stretch of the imagination, and please accept my sincere apologies if this is a total red herring - but I think it might be some sort of truncation-type thing related to the comma (maybe some sort of clash between floating point and integer???)

I can generate the misbehavior Tim sees, but it takes more steps than he lists to get it (on Powerbook G4 w/ OS 10.4.9):

  1. Click target icon in lower right of document
  2. Enter target number: 1000
  3. Click ok
  4. Progress bar looks right
  5. Click target icon again.
  6. Target entry window shows: 1,000
  7. Click ok
  8. But now click target icon /again/.
  9. Target entry window has lopped of last three digits ( has become 1)

HTH,
Greg

P.S. I tried changing my International System Prefs to see if the changes in number formats might explain whether people are seeing these comma issues, but it did not seem to matter (though I did not try rebooting after making those pref changes).

Its not a PPC issue, I’m seeing the same thing in my MacBook. The problem seems to be the comma. When you enter a number with a comma, Scrivener only reads the numbers before the comma (i.e. 50,000 becomes 50). However, if you don’t insert a comma Scrivener automatically assigns one to it (i.e. 50000 becomes 50,000). If you just close off at this point things work as expected. However, as Tim has already said, if you click the area again Scrivener takes the 50,000 (that it assigned) to be 50.

EDIT- sorry, posted this before I saw Keith’s answer here.

Okay, having double-checked this, this is an Apple bug. A really stupid one, too. More specifically - happily, I guess - this is a Tiger bug. I have e-mailed the dev-lists to see if there is a way around it. One way around it would be to get rid of the comma separators altogether, I guess.
Best,
Keith

Hi,

The last three digits get cut off whether or not I manually enter a comma when I type in the number. Just want to make sure that was clear.

Great discussion.

Hi,

The last three digits get cut off whether or not I manually enter a comma when I type in the number. Just want to make sure that was clear.

Great discussion.