Project doesn't open, Scrivener hangs, Text file not found in package: please help

Dear fellow writers,

I’m a long time Scrivener user and I’ve never lost a single comma of work but suddenly I’m bugged:

  • my current writing project won’t open anymore
  • Scrivener hangs when trying to open, I have to force quit
  • console says nothing to that
  • looking at the package content, I can find everything in the research folder, but not the one document in the binder: my text
  • All the backups of this file also don’t open and cause Scriv to crash
  • Local backups on external HD do the same
  • none of the packages show the text I’ve written
  • my text is written in the screenplay format
  • Scrivener 3.0.2., OSX 10.12.6
  • Deadline is looming

I’ve mailed the project to Support, but as it’s urgent, maybe you have suggestions.

Thanks so much!

Here’s the beginning of the hang report:

Date/Time: 2018-04-30 09:58:02 +0200
OS Version: Mac OS X 10.12.6 (Build 16G1212)
Architecture: x86_64h
Report Version: 25

Data Source: Stackshots

Command: Scrivener
Path: /Applications/Scrivener 2.app/Contents/MacOS/Scrivener
Version: 3.0.2 (1506)
Parent: launchd [1]
PID: 618

Event: hang
Duration: 1.10s (process was unresponsive for 154 seconds before sampling)
Steps: 11 (100ms sampling interval)

Hardware model: MacBookPro14,1
Active cpus: 4

Fan speed: 3095 rpm

Could you show a screendump of how the project looks if you right-click and then click on Show Package Content and then click down so the text content is really showing, like this?

Thanks for replying! I’ve tried to attach a screenshot, the forum system doesn’t let me. I’ll try to figure it out …

It could be that your image is too big.

Do you keep your project file stored where in a place that syncs it with a server, like icloud or google drive or dropbox by any chance?

The image is a standard screenshot, png 144 kb.

All files are stored locally (internal HD, external HD), backups are on Dropbox, but not shared with anyone.

Now it works (attaching the image, that is). The folders in »data« are empty except for the ones containing research files.

Little update:

I haven’t solved the technical side of this problem, I have, however, rewritten the stuff that I can’t find anymore and I think it has improved a lot in the rewrite. So the solution to this problem is not urgent anymore, now it’s just for technical interest :wink: