project file size

I’m wondering if my Scrivener project file size could be too large? Recently I’ve noticed that there’s a delay when opening the project and also when switching from different documents within the project. It seems to have started after I inserted a bunch of graphics into a text document. I ended up deleting the graphics because they slowed the loading of the document so much. But the delays continue. Altogether the project is about 800K words, but includes various multimedia files too.

Can’t tell what your problem is, but it’s not likely file size. My current major project is at 20.8 MB, including graphics, and I don’t notice any slow-down.


Including a lot of graphics in the text editor has been known to slow down Scrivener a bit. Unfortunately there isn’t much of a way around that without changing the workflow because the problem is that now you have far more material to save whenever you change the document than you once did. This can cause brief periods of lag while typing, as auto-save becomes more noticeable.

On the bright side, there are a number of ways you can resolve the problem:

  • Bump the auto-save interval up a few seconds in the General preference pane. Note this is an idle timer, so you probably don’t need to change it by much. It doesn’t literally save every two seconds by default, but whenever you pause for two seconds. If you tend to pause for two seconds and start typing, then you’ll run into lag if there is a noticeable delay while saving. Changing this to four or five could be enough to make the problem “go away” for good. The downside of this is that auto-save will run less frequently. If you push it up too far, it may never run at all, meaning you’ll have to go back to acquiring the habit of manually saving with Cmd-S now and then.
  • Consider using image links instead of embedding them. Embedding is convenient, but it’s really only practical for small-scale usage. If you’ve got lots of figures in your work, it’s nearly always a better idea to link to images on the disk. Use the Edit/Insert/Image Linked to File… menu command to add graphics. Note when working this way you need to keep the images in a stable location. If you move them the links will break.
  • A slightly safer way, in terms of link breakages, is to link to images in the Binder, since that just uses the image name and not its location as well. The drawback to this method is that you don’t get a thumbnail while writing, because the link will be typed in. To create a text link to an image in the Binder, type in: <$img:binderName>.

If you take snapshots frequently (including if you use the Sync to External Folder function regularly with the snapshot option enabled), take a look through your documents to see if you have a lot of unnecessary snapshots and delete whatever you don’t need, especially if you have any of the document with all those graphics before you deleted them. There’s a bit of a bug where Scrivener reads all the snapshots from the disk when loading a document, so once you’ve got a big number of them, you could get some slowdown, and having a lot of embedded graphics probably can affect how soon that starts to hit you. (To be clear, the only time I really noticed this as a significant issue was in a 9K+ word document with some 80 snapshots, but that was all text.) That will be fixed for a future update, but meanwhile just deleting the snapshots should speed things up if that’s the problem.

Changing the auto-save interval to 4 seconds worked! Thank you.