Project incompatable, can't fix it!

I downloaded the beta, then on the 8th of November I downloaded an update to version 1.0 to fix some minor problems I was having. I haven’t had any problems up to now so I never went and looked for another update.
I was typing away when my computer crashed and then I restarted it and clicked on scrivener in my startup menue (how I always get into it, usually from there I get the message about when my beta version will expire then it takes me straight to my novel) it said my project was incompatable with this version of scrivener!

I have looked in my documents and I have two versions of my story, one that has only stuff from the 1st to the 8th in it and I can access and open. This was created with the first beta download. Everything since then I can’t access on scrivener, because I think I can’t access the beta 1.0. Is that right? The files are still there.

I made a copy of my folders using the windows explorer thing so I could mess around and not stuff up the origional.
First I tried

that someone suggested here … nt-5533467

That didn’t work so then I tried downloading the new update, but that made no difference. I have been searching for a few hours and found this Corrupt/Incompat Project Files [User Workaround/"Fix"] but either I cannot understand the instructions or I cannot do it.

What is the first step in very simple wording? I have tried going into the explorer where I can see the folders, double clicking on the folder with my project name, then I see Files, settings, snapshots and project. I right click on project and go to “open with” and get the option to open in scrivener, scrivener exe or with another program. When I go to open with another program I cannot choose any text programs (word, notepad etc), only for things like google and photogallery and stuff.

Am I clicking on the wrong thing entirley? If so where do I find what I am meant to right click on?

Please help, due to my work schedule this was my second last day to write to win NaNo and now I am down to one day and I really want to be able to access my NaNo before then so I can win and then buy scrivener with the winner’s discount!

Thank you for any help anyone can give me!

Okay, my poor PC is flipping out really badly, so I can’t actually test this. But going off the instructions in the linked thread and what I remember of the Windows set up and how the Mac version works (which is what I use), I think what you want to do is look for the .scrivx file. Right click to choose open with and then choose other program, as you did. My guess is that there’s a list of programs Windows is suggesting you use and graying out other options because they’re not known to be able to open that type of file (xml), but you should be able to choose somewhere for Windows to allow you to select any program. Choose something like Notepad or Wordpad and open the file, and if it gives you a message saying something along the lines of “this program might not be able to open this type of file! open anyway?” just say yes.

Ok. I just ran into this exact same problem. I’ve been using the scrivener beta to create my NaNo project (which I was seriously behind on) and this is the last shot I had at catching up. Can someone post some step by step, non tech savy directions for getting into my project. At this point, I’d be happy if I could just copy and paste it into a Word document for back up sake.

Thanks so much.

(Oh, and I can’t get the file to open in any version of Scrivener).

Okay, still having issues with my darn broken Windows machine, so I can’t step-by-step the process with altering the index file as StarTigress describes in the post referenced above. However, for simple recovery of your actual writing to open it in Word or wherever, although it’s piecemeal it’s easily accessible as all the stored .rtf files that Scrivener creates. Open up your project file in Windows Explorer (“myproject.scriv”–it’s probably saved in your My Documents folder by default, but if you don’t remember where you stuck it you can do a Windows search for “.scriv” or the project name) and navigate to the Docs folder within that (I believe it’s Files\Docs) and you’ll see a list of numbered .rtf files: these are your Scrivener documents and can be opened in any text editor that works with rich text (so Wordpad, Word, GoogleDocs, etc.). Best thing to do if you’re going to be working on them outside of Scrivener is probably to copy the batch to another location before you start messing with them.

Ok, thanks for the attempts at help so far, much appreciated. It looks like I am clicking on the right things, but just can’t force it to open in word no matter what I try as the options aren’t even there even if I try to make them be!

I right click, choose open with, click the choose defauly program (my only option rather than the scrivener ones) then in the other programs there is NO options, so I click browse to look for other programs and there are heaps of files but no programs, so no notepad, no word. To try an open it in word I made word an icon on my desktop (because there is a desktop option) and I clicked desktop and then the icon of word and it did nothin, it seemed to think it was opening with the icon of word.

To test I tried this with the old file from the 8th that still works and it won’t open that in word either.

Other things I have tried is to make a copy of the old file from the 8th that I can access and copying files over to that from my most recent version, and it opens fine but with just the information of the 8th, not the stuff I copied over so that didn’t work.

What version of Windows are you working on? I’m working with XP, but I can go fool around with Windows 7 to test this out possibly.

For mine, I can right click the project.scrivx file, choose “Open With” and then there are a couple default options, including Scrivener, and also “Choose Program…” Selecting this last brings up a dialogue with a list of options separated into Recommended and Other Programs, and Word and Notepad are both on the list. However, there’s also a Browse option, which might be what you’re seeing, and which then opens up what looks like a lot of folders and files. You can actually choose a program from this, if you know where it’s located, so for instance if you navigate to C:\WINDOWS\System32 you can find notepad.exe. (At least, that’s where it is on XP; you could run a Windows search for the program name to find the proper file path.) Once you’ve chosen it, the icon and program name will show up in the list of “Other Programs” and you can then choose to open the .scrivx file with it.

Does that work for you?

Thanks for the repy!
Right, I get that part with the sepperation of scrivener and other recomended programs, but there aren’t any recomended which is why I am browsing like yu have said.

I moved word onto the desktop so I could find it there easilly but it thought I meant just the icon. I’ll have a wander round and see if I can find word elsewhere to open from there.

And I am using windows vista.

Yeah, what probably happened is that you just created a shortcut on the desktop. You need to open the actual .exe file. If you can run a Windows search for “Word” then you should be able to get it to come up and be able to check the file path so you can see where it’s kept on your system.

Anyway, I’m being stupid. Just open Wordpad, then click to open a file and browse your way to your .scriv folder and open the .scrivx. Make sure when you’re in the “open” dialogue that it says “All Documents” and not just text files. That should work fine.

What you could do is create a new project in Scrivener, then open your “incompatible” project folder in Windows Explorer (the “myproject.scriv” folder) and go down to Files\Docs, then drag and drop your .rtf files into the open Scrivener project to import them. (You could do this with your version from the 8th also; you’d get some duplicate sections, since you’d be recopying all the sections written between the first and the eighth, unless you were careful to check the modified date on the files in Explorer before you copied them, but you could easily delete the extras, and this way you’d maintain all your document notes, synopses and meta-data for those earlier segments.) Another option would be to open the files in Word or wherever and then copy/paste the text into new documents in the project.

Ok, I tried following that path idea, but still nothing happend when I did find word to click on.

I have opened wordpad and I get to the folder, but the project link isn’t there, just the files, settings and snapshots folders.

I have tried dragging and dropping the .rft (well, copying and pasting, is that the same?) files into a copy of the one from the 8th but while it will still open none of the data is there that I have moved in, just the old stuff from the 8th.

I coupld copy and paste, but I will need to remake most of my chapter folders, all the files with the index cards and copy the information on them and set the POV and status and so on. I do realise its not as bad as loosing everything but its a lot of work because it was AFTER the 8th that I started doing my forward plotting on scrivener and plotted it all out, so I have none of that. If I did I would just copy the text over into the waiting files.

I don’t like the idea of recreating my entire document and putting all that work in only to face the posibility that this will happen again with no way to stop it or know when it will happen or fix it easilly if it does happen.

Make sure that you’re looking at all file types and not just text documents. The .scrivx file won’t show up with the regular WordPad default settings, but you can choose to see everything (there’s probably a drop down menu for choosing file types) and then you’ll be able to open the .scrivx file.

It depends; are you copying and pasting between two projects open in Windows Explorer, or are you importing the .rtf files into a project open in Scrivener? The former won’t work the same way and the files most likely won’t be recognized when you open the project because they’re not in the index, etc. that Scrivener builds for the project. The latter will work like importing any other kind of file into Scrivener.

I do understand though what you’re saying with all the work that you’ve put into this; this can restore your text, and your synopses and notes and such, although those will require a little more patient moving around, and really you can also restore your labels and status settings and such, but that’s again more time-consuming if you’re piecing it together by reading an xml file in a text editor. I’m sure there’s a better way, and I’m sorry I’m just not familiar enough with the Windows beta right now to offer much more help. There are a couple other threads where people have some other suggestions of things they did when running into this problem, so maybe some of that will work for you? And maybe someone better informed will hop in here to help you out, too. :frowning:

Just an update that MimeticMouton has fixed it for me :smiley::smiley:

Thanks to you all for putting up a very frustrated little me!
The moral of the story is, if you’re new to scrivener then don’t just keep a backup of the text because if something happens to your scrivener you may discover you get massive writing block (for the first time since you started writing in scrivener!) when you go to try to write in the word file. I think because scrivener workes in with how my mind works and doesn’t get in the way I never noticed how much it was helping. I think they should come up with a new slogan “Scrivener, better than you think it is!” lol. I’m reminded of when you sell makeup to ladies, you put it in their hand to hold and they are going “oh, I don’t know, I really shouldn’t be spending money on me…” and you go “ok, give me the make-up back” and they go “No! it’s mine! where do I pay!”

Thanks! My file is scrambled and totally out of order, but I’ve got my work back, less a couple thousand words, but I’m back in the running. Yippee!

(Edit to put the fix at the top, because this was a messy, messy post)


  1. Open the .scriv folder of the incompatible project, make a duplicate of the .scrivx file within the project and delete the original. (You can rename the copy to just “project.scrivx” if you like; it won’t matter.)
  2. Open Files\version.txt, select all and type “16” (no quotes) and save it. Bang, your project should work.

— (further notes from earlier, in case anyone cares)
All right, now that I’ve done some further testing: It’s the version.txt. Someone mentioned this in another thread, but I think I had a problem the first time I tried this so it didn’t work. For reference, what I did for Kathelyne was create a new empty project, then transfer the relevant files from the broken project into that (via Finder, although it could’ve been done with Explorer, it’s all the same), but I was in a hurry so I skipped some parts that might’ve been bad and just made sure I got it up and running. Turns out, after further experimentation, that absolutely everything can be copied and replaced except for the version.txt, which in the corrupt project is blank but which should contain simply “16” (no quotes). I had issues with this because if I attempted to change the file (open up the .txt, type “16” and save it) after I’d already tried to open it the attempt didn’t work, presumably because it already used the blank file for whatever it needed.

Something related to the version.txt file is presumably getting saved with the .xml file somewhere that’s not a part of the file itself (sort of–NTFS alternative data streams, maybe?) and gets lost when it’s copied. For some cases, then, it’s possible all you’ll need is to fix the version.txt file, if the .scrivx file is “fresh,” but it won’t hurt to just do the whole thing with the duplicate and it’s probably faster to just do it than to test it in between.

I’ve tried everything to no prevail. Rather stupidly I started a full project in the beta, and until today I had no trouble. I was ready to go on to my next chapter, so I added a folder. My project crashed, and it will no longer open. I saved several backups, but none of them are working either. I’m just writing to let you know, if all else fails you can still go into your scrivener folder, then into Folder->Docs and pull out each individual RTF and reimport it into a new project. A pain, but at least you have everything!

Hi Bouke,

Rats, you tried the fix above and it didn’t work? (I’m going to go edit that in a second to make it simpler, since I was tired and just slapped the cleaned-up fix on the end of the previous post.) I know it fixed some other projects, so I guess there are just multiple issues floating around that are creating the incompatibility. Could be you have a corrupted file somewhere in your documents. Meh. Sorry it didn’t work.

Actually, I added an outline earlier this morning,(saved as a .rtf in word) and when I tried to bring it back, scrivener crashed. I think that may have been the problem. In the future if I have a corrupt doc, could I just delete it without changing anything in the binder code? or would I have to remove it in both places?

**Also, my spelling highlighter isn’t working anymore in the new project. I have it enabled, but it won’t highlight any mistakes pasted or typed. My font toolbar is also nowhere to be seen. **edit I found the format toolbar option, but my spell checker still isn’t working. I am still new to Scrivener, but I checked all the options I can find. My last project was working perfectly, (until it crashed) all I did was start a new project, and import the DOCs out of an old corrupt project. For some reason a lot of the scrivener features aren’t working anymore.

Yay. Thanks MM. Putting in 16 to the versions.txt allowed me to open the file. Now I just have the problem that everything I wrote (and saved at 10:58 pm) before the 11 pm crash – two long scenes – are corrupted rtf files and show up as boxes. I am sure there is a way to get part of the text out of these corrupted rtf’s and am posting my question elsewhere.


MimeticMouton, I registered just so I could thank you for your fix. I just blew a circuit breaker while I was working, and got powered back up to find my project was suddenly incompatible. I figured I’d check the forums here before I panicked, and your fix put me right back in business. Thank you! :smiley:

Glad it helped! It’s a weird thing…I’m sure it will get fixed eventually. After poor Lee has a chance to sleep and enjoy the holidays. :wink: