Project no longer opens

Hey all. Having a touch of trouble with my major work project, sitting in my Dropbox as a scriv file. Installed scrivener on my iPad Pro lady night and synced from Dropbox my 60 odd mn project. Was devastated about the lack of indentable lists (which almost destroys my workflow on iOS scrivener) but well, moving on. Was able to at least read my project, even if making new list documents is a bit difficult. Synced and closed.

Installed the app on my iPhone as well and synced the same project there and opened it to read some of my data, all still working fine. Synced and closed.

Went to open the project on the iPad again and touch it in the binder, and it won’t open. The project simply flickers briefly and then returns to the “menu” for lack of a better word.

I have tried synching it, deleting and redownloading the project, and deleting and reinstalling the app and then the project. Still will not open the project.

Now it won’t open on the iPhone either. Just sits there.

Anyone experiencing this or having any thoughts?

Can you think of anything else you might have added to the two devices beyond this project, such as custom fonts, presets from the Mac, etc? Also does the project open fine on the Mac?

Hi ioa,

No, no custom presets, no custom fonts, etc. Just a novel template from the Mac (because I like the structure) and then nested folders/text with a few PDFs in the binder.

It did still open on the Mac when I got home to test it, and after re-saving it on the Mac and synching it again, it now mysteriously opens again on both devices. So… Problem solved for now but weird behaviour? Has this cropped up before?


Well crashing on load is a bit of a generic symptom of untold quantities of potential bugs—as with most crashes, the crash itself is rarely informative. It’s the circumstances around the crash that can illuminate what is going on.

The custom formatting and fonts possibilities that I mentioned are one way this could happen—if for example one of your Mac presets contains formatting that the iOS version wasn’t anticipating, when it loads the project and attempts to build the style preview panel in the formatting pane, it’ll crash.

PDFs are a potential vector for this kind of crash, it could be the iOS version is having difficulties parsing them, and because of that, during load when it tries to rebuild the search index using the text of the PDFs, it crashed. Then you opened the project on the Mac, which successfully regenerated the search index, meaning the iOS version now no longer have to process the PDFs when you load the project, and it works.

Just a theory, we could try it out ourselves if you don’t mind sharing copies of the PDFs in question (feel free to send me a PM with them if you’d rather not attach them to a public post).

Thanks for the reply ioa. I’ve sent you a PM with the PDFs attached.

The only real formatting that the mac version has that the scrivener version doesn’t is indented lists with multiple layers, but they display fine, just can’t be built on the iOS platform to my understanding?



No luck here with getting the crash when testing with these PDFs.

Let’s just a simple reset, going back over your description, this reminds me of a problem I had as well, that I solved by resetting the Dropbox cache. In, go into the Scrivener section, then in “Reset Scrivener”, set the “Clear Dropbox Sync Cache” toggle and then restart Scrivener.

Just happened to me today. Clicked on the project file, just “flickered.” Tried the “Reset” option. Didn’t work. Re-saved project on Mac, didn’t work either. (Project was fine on the Mac though, no PDF’s or strange formatting, only Scrivener text). Deleted Scrivener on iPad, re-downloaded and now all is fine…

Mac OS X 10.11.6

IOS 9.3.4

A note on the reset options – in order for them to work you need to restart, which means removing the app from memory by displaying it in the app gallery (double click the home button) and sliding it up so that it’s no longer in the gallery, then launching it again. If you didn’t do this, then it’s something to try if this happens again. If you did – sorry, :blush: I’ll shut up now.

Thanks for the info. No, I didn’t know that, but if it happens again, I’ll certainly give it a try.

I had this same experience today, with the “flickering” back to the menu.

It was the first time I tried using iOS outside of my house, away from my Mac and wifi. I tried it several times, no luck. I closed out the app. I did a hard reset on my phone. Then I unlinked the app from Dropbox and relinked – no luck. Lastly, I deleted the app and re-downloaded. Still no luck.

When I came home, I opened my project on my Mac, and all looked fine, apart from when it opened it said it was “checking for orphaned items.”

I’m not sure how anything became orphaned as I made certain Dropbox was done syncing before I left the house. The project opened on my Mac fine though, as I said. I made a test change, saved, synced, closed. Then reopened on iOS. Same problem.

Eventually, after several goes of this, it opened on my phone, but I didn’t do anything differently that I can find.

I’ve gone through a few more rounds of making changes on either platform, syncing, closing out, and opening on the other, and it seems fine right now.

The only thing I can think of from what has been mentioned is that I’d imported custom icons. I’ve just tried removing these to see if it makes a difference, or if the problem resurfaces. (Oh, and I do have some images saved in the project, but I don’t imagine those would cause an issue?).

Regardless, I’ve gotta say I’m THRILLED with this app. It’s absolutely gorgeous and so worth the wait (and the price!). Thanks! :smiley: