Project Target only counting text viewed in the session

I just bought a new Mac and am now running Scrivener 2.7 on Mac OS X El Capitan (10.11.5). I was previously running Scrivener 2.6 on Mac OS X 10.6.8.

When I open my project and pull up the Project Targets, the Manuscript Target is incorrect. It is low - my project has around 70k words, but it opens showing only 16,774. As best I can tell, it seems only to be counting text that has been viewed in Scrivener for that session.

Most of my icons in the binder are shown as a blank page, not read. (See “Wrong Count” screenshot.) I can fix this by going though the binder and ensuring I view each text file. Once I’ve done that, the “blank” icons change to indicate there is text in that file (see “Right Count” screenshot), and my manuscript target word count is corrected. (Usually. Sometimes I view all of the pages, and the word count is still short by 500 or a 1000 words or so. If that’s the case, I have to close the file, reopen it, and try my fix again.)

I use both Mac & Windows versions of Scrivener to access this file; this behavior is only happening on my Mac and only since I upgraded to Scrivener 2.7/El Capitan. This isn’t a huge deal; the work-around takes a couple of minutes, but it is an annoyance.


I upgraded to Scrivener 2.8 today, and this behavior persists. I finally had a few minutes to give you more specific steps. Of course, if no one else is experiencing this, it may be only my file. However, this is not happening when I open the same file in Scrivener for Windows.

I know you have a lot going on with the iOS update coming shortly. Thanks for any attention you can give this one.

Replication steps:
You will need a scrivener file with significant text across multiple files. In my file, I have folders nested within folders (i.e., Manuscript > Book 1 > Chapter Title > Text file). The text files range from 500-3000 words each. It will help to know the actual total of words in the manuscript prior to attempting to replicate the steps.

  1. Open Scrivener and load your file with text populated.
  2. Go immediately to Project > Show Project Targets.
    In my case, the manuscript target is lower than the actual word count, and my icons on the left-hand side are blank pages, as if the text files have no synopsis or content.
  3. Close the Project Targets window.
  4. Select each of the text files long enough to have the text appear in the editor. The icons should change.
  5. Go again to Project > Show Project Targets.
    In my case, the manuscript target now reflects the correct word count, including all text files viewed.

Console Log
This doesn’t crash Scrivener, but here is the Console log as I perform the steps above to recreate the error. Nothing is bolded for me, but I expanded the ones that could be expanded, in case it helps.

7/18/16 12:49:39.441 PM lsd[270]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist
7/18/16 12:49:39.835 PM Scrivener[774]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.5 instead of 10.11.5. This is not a bug in Gestalt – it is a documented limitation. Use NSProcessInfo’s operatingSystemVersion property to get correct system version number.
Call location:
7/18/16 12:49:39.835 PM Scrivener[774]: 0 CarbonCore 0x906c8e3d ___Gestalt_SystemVersion_block_invoke + 135
7/18/16 12:49:39.835 PM Scrivener[774]: 1 libdispatch.dylib 0x9abfe83f _dispatch_client_callout + 50
7/18/16 12:49:39.835 PM Scrivener[774]: 2 libdispatch.dylib 0x9abfe71b dispatch_once_f + 78
7/18/16 12:49:39.836 PM Scrivener[774]: 3 libdispatch.dylib 0x9abfffa5 dispatch_once + 31
7/18/16 12:49:39.836 PM Scrivener[774]: 4 CarbonCore 0x906448e1 _Gestalt_SystemVersion + 1047
7/18/16 12:49:39.836 PM Scrivener[774]: 5 CarbonCore 0x9064408a Gestalt + 154
7/18/16 12:49:39.836 PM Scrivener[774]: 6 Scrivener 0x002f14b0 Scrivener + 3081392
7/18/16 12:49:42.075 PM Scrivener[774]: NSSoftLinking - The ShareKit framework’s library couldn’t be loaded from /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit.
7/18/16 12:49:42.235 PM WindowServer[170]: disable_update_timeout: UI updates were forcibly disabled by application “Scrivener” for over 1.00 seconds. Server has re-enabled them.
7/18/16 12:49:42.293 PM WindowServer[170]: common_reenable_update: UI updates were finally reenabled by application “Scrivener” after 1.06 seconds [0.94fps] (server forcibly re-enabled them after 1.00 seconds [1.00fps])
7/18/16 12:50:15.833 PM lsd[270]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist

I just upgraded my WINDOWS version of Scrivener to Version: 1.9.6.0 - 03 Aug 2016 and this issue is now occurring in Windows as well. Only the work-around doesn’t work.

Now my manuscript word count is permanently inaccurate in Scrivener for Windows.

Did you get a response about this?

I think I’m having a related issue, but before posting a separate threat I wanted to know whether there might be something wrong with the session target counter in general. On my end it seems that the “Count documents included in compile only” checkbox is not working, i.e., I can’t turn it off (it always only counts documents included in compile, no matter if the box is checked or unchecked).

I have not received any response about this issue. I eventually assumed it was a flaw in my file caused by the upgrades and spent a couple of hours rebuilding the manuscript from a blank new file. That seems to have fixed the issue (at least so far), but it was a pain. It also makes me extremely hesitant to upgrade.

I did find that if you change the “Include in Compile” checkbox value for any of the sections of text, you need to close the Project Target window and reopen it to see the corresponding change in the value. In other words, the box is dynamic when you’re typing text, but not dynamic when it comes to checking/unchecking the “Include in Compile” box. That requires you call up the Project Targets window again to refresh the count accordingly.

I hope that helps!

I’ve seen people have success with the function “Save and Rebuild Search Indexes”, located under the Tools menu on Windows, and available under a different menu on the Mac when you press the OPT button.

I can’t recall which of the menus it is on the Mac, but try the leftmost menu first, pressing and releasing the OPT key; if it’s the correct menu, the option to rebuild search indexes will appear under that top-level menu when you depress the OPT key, and will disappear when you release it.