Project target word count zero

In the target pop-up, click on “options”.
Then make sure you are set like this:

Especially the first one. It needs to be unchecked, else you get only the count for the compile group. Which may very well in some cases give 0.

What do you get from Project / Writing History ?