Project Targets has stopped counting

Hello there. :smiley:

I started using Project Targets as a sort of NanoWriMo incentive, and it was all working astonishingly well until this morning. Now, for some reason, the count as stopped moving. I think I’ve managed a good thousand words or so, but the count has stayed the same.
Now I looked at the option settings and it seemed that I hadn’t set Sunday as a writing day, so I changed it, but the count is still not moving. I’m not sure if I’ve hit a bug (unlikely) or I’ve forgotten to set something else (more than likely). Any ideas?

Thanks.

A screenshot of the Target options and your binder set up might help. Off the top of my head I’d guess maybe you’re writing in a document that’s not set as part of the current compile group or is otherwise excluded due to the option settings, so it’s not getting added to your count. Is it the session count or the Draft count that’s not moving (or both)?

Both counts are stuck, and I’ll sort out the screenshots when I get home.

Thanks :slight_smile:

Okay, the documents are all included in the compile list, so at least I got that bit right.
Screen Shot 2011-11-08 at 18.18.31.png
Screen Shot 2011-11-08 at 18.19.18.png

What about your compile settings? Note that you have “Target applies to current compile group only”. This means that if you’ve changed your compile settings only to compile a subfolder, or a collection, or suchlike, anything outside of that subfolder or collection would not be counted. If that’s the case, just un-tick “Target applies to current compile group only”.

All the best,
Keith

Good point.

Okay, I’ve unpicked that, and had a look at the compile settings: every document is selected for inclusion, including the one that’s giving me trouble. Still not working.

Let me just try something out here…

Okay, now if I go back and start typing in an old document it starts counting again.

Now if I start typing in the trouble document …

blimey! It’s started working again without any changes to the options.

I started typing troubledoc on Sunday and I noticed it wasn’t counting. I checked the options and saw that I didn’t have Sunday set as a writing day. I set Sunday as a writing day and it still didn’t count. Perhaps something got stuck?

Anyway, it all seems to work now :smiley:

Now this is odd. I restart Scrivener and it’s stopped working again.

:frowning:

And this time, it won’t restart.

Gaaah!

As you were. It’s turns out it’s user error!

I had the document in the wrong folder. It was inside a folder sitting outside the draft!

Sorry!

:blush:

That would explain it. :slight_smile: Glad you got it sorted!

All the best,
Keith

P.S. There is an option for including documents outside the draft in the session target.