Project Targets not working

Hello,

I think I am experiencing a problem with my Project Targets.

I last wrote a few days ago. I did not close Scrivener, but, instead, closed my laptop. When I began my writing session today, I opened my computer and began to write. I wrote this morning for ninety minutes in a section that is included in compile. When I pulled up my Session Target, it stated that I had only written 267 words. I thought it odd, so I highlighted all that I had written thus far. The bottom of the screen told me that my selection contained 1,007 words.

I am using Scrivener for Mac with Yosemite 10.10.1. When I select search for updates within Scrivener, a dialogue box informs me: Scrivener 2.6 is currently the newest version available.

I have the following selected (in options) within Project Targets:
•Count documents included in Compile Only
•Deadline is set
•Reset Session count at midnight
•Automatically calculate from draft deadline

I have hit option and selected Save and Rebuild Search Indexes. I have closed Scrivener. I have compiled and exported my manuscript to a pdf. I restarted my computer. Session Target still says word count 267.

Would love input on this. :slight_smile:

I love my Scrivener. It helps me feel successful. It helps keeps me focused. Today, I don’t feel so successful.
Sad face.

The session counter is a good deal simpler than the total progress bar. You needn’t worry about your compile settings, and I don’t believe the search index is even a factor since this only counts your actual input into the text editor and stores that number until it is reset (your session activity isn’t really derived from what is on the disk or in any index, but a side-product of the keyboard events you trigger when you type, to get a bit more technical about it).

So in the “Session Target” section of the options pane, there is one checkbox that matters to this equation, Count text written anywhere in the project:

  • When enabled: absolutely any text in any text file, so long as you’re typing in the main editor, will be counted.
  • When disabled (default): Only documents descended from the Draft folder with their Include in Compile checkboxes enabled (in the General inspector pane) will count your progress.

So the best thing to do would be to test typing in a few different files that you know you worked on. Do you see any of them not counting your input? If so check its path and compile flag.

Hello AmberV,

Thank you for your prompt response.

In reference to : “Do you see any of them not counting your input?”

The answer is no. I did go through and check multiple files to be sure that files with the “include in compile” box checked off were attributing to the total word count in the Session Target count and they were.

These are the steps I took today:
1.) I opened my laptop (after not closing Scrivener a few days past), picked up where I left off in the open file, worked for 90 minutes,
2.) opened Project Targets, saw that the Session Target word count was at 267. I did start test typing to see if it was tracking at all, and the number did increase. But, again, the total word count for that session seemed off, based on the amount of time I had been typing.
3.)That was when I selected the copy from where I had originally started working in that session and highlighted all the way down. The footer bar of my open window stated "Selection - words: 1,007. Nothing close to the 267 of the Session Target.

When I did a search of “session target not working in scrivener” I arrived here: literatureandlatte.com/scrivChangeList.php

and found this line under Minor (Usability):

•Fixed bug that could cause project word count to be reported wrong in the project targets panel if the project had been open a few days.

Might it be that this bug is not resolved yet?

That bug shouldn’t apply to you because you’ve closed Scrivener in an attempt to resolve the problem. It only impacted those who leave projects open for several days in a row.

Would it be possible to send a copy of the project for analysis? I could probably figure it out pretty quickly if I could play with the actual data a bit. If that’s all right, use the File/Back Up/Back Up To… menu command to create a zipped copy of the project and attach that to an e-mail to our support address. If it’s a very large project, you should dump the research files out of the copy and empty the trash, there is a 10mb limit on e-mail attachments.