Project Templates

This is probably a silly thing, or my error, but I’ve been reading the forums, wiki, etc. and just can’t find an answer.

I’m using the trial version of Scrivener because my boss loves it more than CeltX or Storymill.

When I start a new project, select say “Fiction->Short Story”, tell it what and where to save, I get the spinning pinwheel of death. This has happened with every project template I’ve tried. If I pick a blank project then it all works.

Using some hints on here, I looked in ~/library/Application Support/Scrivener but there aren’t any templates there. Just backups and logs. I looked in /Library/Application Support and there’s nothing for Scrivener there. I’ve looked at the contents of the app.

So I’m guessing that either the current DMG is missing files, or templates aren’t available for trial users.

I’ve also looked at the website and tried to find a download for the templates.


If you’re getting the spinning wheel of death, then something is definitely wrong that’s not your fault - what you are trying should work, trial version or not. Could you please do the following, which should hopefully glean some useful debugging info:

  1. Run Scrivener and try creating a project from one of the templates that creates the spinning wheel of death again. When you get the spinning wheel of death, then:

  2. Take a look in ~/Application Support/Scrivener/Logs and see if there is a Console.log file there, and if so, open it in a regular text editor and paste its contents in your reply.

  3. If no such file exists, please open from /Applications/Utilities. There should be some error messages pertaining to Scrivener in there - please copy those and paste them into your reply.

Hopefully this will help me figure out what is going on.

Thanks, and sorry that you are experiencing these problems.

All the best,

Just two lines in the console.log

2011-03-30 17:35:52.187 Scrivener[7637:207] Exception detected while handling key input.
2011-03-30 17:35:52.188 Scrivener[7637:207] launch path not accessible

I normally keep apps like this in ~/Applications. Just in case I ran a test after moving it to /Applications and it didn’t make any difference.

I did try to reinstall over the top of the old one, but got a “can’t install. info.plist in use” if that helps at all. (Scrivener is not running, or at least I existed it normally after canceling the new project)

Those two errors definitely indicate a problem, although they are a little vague unfortunately. They appear at the same time but seem different, which is odd. The “launch path not accessible” is interesting, as that seems to suggest that Scrivener couldn’t access the zip library on your copy of OS X. Template files are compressed and Scrivener calls on OS X’s built-in zip/unzip utility on the command-line in order to unarchive them, and this appears to be the problem here.

Hmm, actually, thinking about it, it could be down to where you have installed Scrivener. Are there any spaces in any of the folder names in the path to Scrivener on your machine? The template files are stored inside Scrivener itself, so the unzip utility might be stalling because of space names in the path. in that case, moving it to /Applications is definitely worth a try. If Finder is reporting a file in use, it may be that Spotlight is hanging on to it for some reason - try logging out and back in again and you should be able to move it.

That said, I have tried Scrivener in subfolders with spaces in their name (and just re-tested) and it worked fine, so it may be another problem with the zip library on your machine, but let’s try this first.


Hi Keith,

I’d successfully moved it to /Applications in my last post. It was reinstalling from the original DMG that failed due to the info.plist.

Logging out and back in DID free up the info.plist, so I reinstalled over the top, cleared out the Console.log and tried again. We’re down to only one error now:

2011-03-31 07:20:49.309 Scrivener[37950:207] launch path not accessible

Very strange. When I get to the office today, I’m going to boot off of one of my backup clone drives (this is a MacBook Pro), install Scrivener and try it that way.

I’ve already found one feature of Scrivener that makes my life easier than with my other writing managers… Syncing to Simplenote. I wrote a few hundred words on my HTC EVO Android phone last night before going to sleep. Very cool.

Hmm, this is a strange one. I still think it’s the unzip utility spewing that exception, but Google is returning very little of help at the moment.

Hmm, actually… Scrivener calls the unzip utility using Cocoa’s NSTask, and that has a launch path which is set to /usr/bin/unzip - that would spew the “launch path not accessible” error if it couldn’t find the unzip utility. This suggests that the unzip utility is broken on your machine for some reason. To verify, try this:

  1. Grab a zip file from somewhere and place it in your home directory.

  2. Open from /Applications/Utilities.

  3. Type unzip ~/ (with the file name of your zip file instead).

What happens? Does OS X manage to unzip the file, or does unzip fail to work?

Thanks and all the best,

P.S. Glad you like the Simplenote sync!

Aha! The morning light shines smack in the eyes of this fool.

-bash: unzip: command not found

I think that you found the problem!

I don’t use the terminal for archive functions, downloaded zip archives unpack themselves just fine, but then again, I do have BetterZip installed.

Thanks Keith! (BTW, I’ve been quirky and grumpy I think you called it much longer than you. :stuck_out_tongue:)

I don’t know, my grumpiness at least is legendary. :slight_smile:

That definitely explains the problem, then. Strange, though - the zip and unzip utilities should be part of every OS X install - did you do a custom install?

Thanks and all the best,

Nope, I did a normal install last time of Snow Leopard and XCode. The only thing I’ve done “weird” is that I installed the custom x server from XQuartz for Wineskin (Wine in a wrapper… takes Windows apps and makes self-contained .app files out of them)

Looking at /usr/bin, zip, unzipsfx are there, but no unzip. Will restore off of a backup.

It’s all working fine now Keith! I copied the unzip from my emergency boot drive (plain Snow Leopard install and nothing else) and I’m in business with templates!

I was telling the wife this morning that now there are two great features of Scrivener I’ve found… Simplenote sysnc (which I hadn’t used in the past) and the technical support.

It is really nice to know someone is there when I pull a stupid human trick, or my computer pulls a stupid computer trick. :laughing:

If everything else continues as well as it has, I’ll probably switch. So I’m already budgeting for licenses for both the mac and Windows/Linux versions of Scrivener.

Glad you got it working! And thanks for the kind words about the tech support - we do try our best, but I always prefer it when it’s someone’s computer that’s pulled the trick rather than a stupid error in my code. :slight_smile:

Thanks and all the best,