project wide Font formatting problems

Hi all,

This is driving me crazy and costing me so much time :frowning: despite referring to manual, knowledge base and help files.

I want to change all my docs from the present Font/Size to a new one. But it is so so hard.

I have set the current format, (the one I want for ALL of my docs) in my first doc, as the default via Project/Text Preferences. Though I totally fail to grasp the logic of the tick box re Use Different Default … I want to set ONE default for everything not a different one. I only have one project.
Then I command-clicked all of my docs and chose Document/Convert/Convert Formatting and choosing Font and Font size.

But it only works on some docs and not on others. I have a list of docs in the Characters folder and it won’t work there at all. It change the Font but not the size :frowning:

Also when I click on the doc in the left listing without clicking within the doc, the Font setting at the top of the page is different from when I then click in it…

I am finding the whole Font Formatting thing extremely frustrating and it is putting me off writing :unamused:

Help ?

Quickest way to do what you want, now you have reset your defaults so that all new documents will conform to the font and type size you want, is to open all the other documents in Scrivenings view, click anywhere in the editor, select all, and change the fonts using the toolbar.

  • asotir

Thanks for the reply.

So I have to open each one of 72 documents and manually change the fonts for each one ? Is there no Global setting ?

No, not at all. Here is the step by step:

  1. click on the Draft folder in binder
  2. show its contents as Scrivenings (CMD-1 toggles this view on and off)
  3. click anywhere in the editor window that shows all these texts as one Scrivening text
  4. select all (CMD-a)
  5. select font and size in the toolbar

this will apply whatever font and size you have chosen to all the documents appearing in the editor window - that is, to all the docs viewed as one Scrivening. But any bold or italic or underline formatting, and other such sub-document formatting such as if one paragraph is centered and another right-justified, will be untouched.

  • asotir

I don’t have any document called ‘Draft’.

It sounds to me as though you’re nearly doing things right, but you’re misreading/misunderstanding a couple of the dialogue options.

a) Go to one of the documents where you’re happy with the formatting and click in the Editor.

b) Go to Scrivener > Preferences > Formatting and make sure the ‘Use Formatting in Current Edit’ is checked. This will mean that any new document (in this or any other future project[see footnote 1]) you create will use the same format, so take a moment to make sure you’re happy with the settings.

c) In the binder select every document you want to change

d) Select Documents > Convert > Convert Formatting to Default Text Style.

e) In the dialogue box, there are several options, but they are to preserve individual elements of formatting – so that if you’ve been ticking the font option, then the conversion will leave the fonts unchanged, which I think is what has been causing your problems. There are circumstances where you may want to preserve the indentions in a particular file for example and you’d select the ‘Preserve tabs and indent’ option. But it sounds like you want to change everything, so you should leave all the options unchecked and press OK.

That’s basically it.

Hope it helps.

Footnote 1: The Preferences > Formatting options are the defaults for every new document you create in every project from now on. If you want to change the defaults for this project only, you’d use Project > Text Preferences instead. The rest of the steps are the same.

Note ‘Draft’ is just the name of the top level binder folder in some Scrivener templates. It’s called Manuscript in other templates, or something quite different. It’s irrelevant to how to solve your problem, as long as you make sure you select in the binder every document that you want to change.