project won't open, think I killed it

I used scrivener (pre version 1.54 I’m sure) some years ago on my [now dead] ibook, and there were a couple of projects that I had on there that I thought I might look up again to see what they were about. I’ve managed to copy the files from the disk (which has since died irreparably), and went through these steps to get myself into a right muddle:

  • Copied the projects onto a USB stick
  • Installed Scrivener for Windows demo (as I happened to have a PC handy at the time). Being the later version I thought it might have some chance of working with the file, but platform differences must have gotten in the way. This told me that it wasn’t created for Windows and could not be used - Cest la vie.
  • Performed some step that I can’t recall on the file to try to trick it. Oh dear! The original on the USB stick… what a fool I am.
  • Found my old licenses and downloaded 1.54 for my mac
  • Tried out the project - it would not open with a ‘Scrivener requires updating to open this project’ message.
  • Subsequently, I tried opening a different project that I had also rescued but had not fiddled with in Windows, and it works fine. All projects except the one I want work as they should.

I’m hoping that there might be some way to edit something inside the scrivener project file (which I realise is just a special folder). Or perhaps there’s a way that I can make a new project and drag all the rtfd and xml files and whatnot I find if I explore into the project. This I don’t know, and noodling around in “working” projects trying to figure how they operate has left my head severely scratched.

Tips please! Otherwise it’s the arduous task of pulling all the raw texts out and trying to remember where they were on the boards, and what all the extra files were for and where they went. I shouldn’t have fiddled in Windows - wretched thing. I’ve tried to remember what I have done to it in Windows but what I have typed here really is all I can recall about it (the process was drawn out over many weeks).

Since it sounds like you have access to a Mac, why not download the 2.2 demo and use that to upgrade your projects? Then they will be ready for Windows. As you noted, the problem is platform specific stuff. When the 1.x format was designed there was no anticipation that there would ever be a Windows version, and it uses a lot of a Mac specific stuff like binary .plist files and RTFD. The RTFD could probably be handled with a custom parser, but the main storage files just aren’t feasible with the Cocoa technology handling them.

As for the one project that got damaged, in step one it sounds like you have an original copy that you got onto the flash drive in the first place, can you get that one back? That would be the easiest thing. If you can no longer do so, then I would try using the 2.2 version to recover it. If you can’t open it in 2.2, which might be likely if Windows cannot, then try creating a new blank project and using File/Import/Scrivener Project.... That can sometimes recover projects that otherwise won’t open. If none of that works, feel free to zip it up and send us a copy of the project to AT literatureandlatte DOT com. We can sometimes repair damaged projects.

I don’t have the copy on USB, that is unfortunately the one that I think I screwed up by trying to open it in Windows. And the original disk I copied it from is now dead, so all I have to work with is in the USB stick.

Taking the new version and doing anything with the file doesn’t appear to recognise any of the rtfd files inside its contents (if I context click and sy “show file content” then I can manually nose through the various bits of information - but none of it is structured in any way that I can see. It is all just numbered files - I guess the structure of it was stored in a file that is now corrupted.

I tried making a new project and importing a scrivener project but it was blank. The file is a few megs big, but nothing comes through in 2.2 if I open or import it; examining the file I see that it has text, images, reference documents, that sort of thing.

Looks like it’s time to pull the file apart and just start again with the peices.

The .scrivproj file is the one that is responsible for turning the big list of numbered files into a structured outline. Did that file get renamed, perhaps? If it got removed, I’d check the recycle bin on the PC for it.