Project won't open

My scrivener project won’t open. Thought the project might be corrupt and tried using the back-up. The same problem persists when I try opening the extracted back-up project. This is the case for the last few back-ups. An older back-up of the project works, but then I loose lots of work put-in after that.

Any way to resolve the issue, or should I settle for the old back-up?

Any help is appreciated, Thanks in advance.

Too little information… you need to give a more detailed background.

What version of Scrivener?
What did you do prior to getting this problem?
Where are you saving your projects and your backups?
Etc…

Sorry for that.

  1. I’m using Scrivener 3.0.2 on my iMac 27", running latest MacOS.
  2. The project was fine when I was working on it. I had saved and quit the file and went on to work on a different Scrivener project. Once I was back to this project, I had this issue. I’ve faced the same problem a couple of times before, but then the back-ups saved me. But, this time the back-ups also don’t work.
  3. Both my project and my back-ups are in the local drive, albeit in different locations.

And exactly what do you mean by “won’t open”?

It literally doesn’t open. The Scrivener project templates window is up but the project doesn’t open, the loading icon keeps spinning forever.
Even when I open Scrivener and then try using “Open an Existing File” the loading icon keeps spinning.

Have you tested to restart your Mac? And restart Scrivener?

(You don’t have to cite when you answer the previous post; it just wastes space)

I tried both, it didn’t help.

This sounds as if there is something else going on. Several backups and the active project all going wrong simultaneously sounds strange. To me it seems that you must have done something else than just close the project, open another project, close that one and going back to the first one.
And getting the spinning ball sounds more like something else is keeping your Mac busy.
And saving on your local drive is literally on your local drive? You did not activate Documents on iCloud Drive?

But that is the case. I worked on another project for a few days and now when I’m back at it, it won’t budge. A couple of my back-ups and my active project have gone wrong. I don’t remember doing anything else.
And the spinning balls, Scrivener is the only active application and it happens whenever I open a project that is corrupt.
I haven’t activated my Documents to sync to iCloud, and the files are only in my local drive.

Is Scrivener set to reopen the last project? So when you start Scrivener, does the problematic project automatically try to load? Do you get a specific error message at any stage?

If Scrivener is trying to load the project automatically, you could try opening Scrivener from the applications folder while holding down the shift key. This should force Scrivener to start without trying to automatically open the project. You can then try opening the project from within Scrivener…does that work?

When you worked on the project before it locked you out, did you add anything such as a PDF or image file?

Scrivener projects are packages, and it is possible to right click on the project in the OS finder window and use the ‘show contents’ command to get inside the project. This is risky as it goes against the app’s integrity, but you might be able to remove an errant file (such as a recently added PDF) or recover the raw text in the RTF files that Scrivener projects are made of. Before you delve into a project’s innards, duplicate it in the finder so that you only work on the duplicated copy and don’t destroy the original.

You could also contact tech support on mac.support@literatureandlatte.com. If you are able to zip and send the project to them, they might be able to work some magic for you.

If Scrivener is the only app causing issues on your Mac, it might be worth deleting the app, cold booting the Mac, and then reinstalling a fresh download of the most current version of the app (from this site or the App Store). Your projects live outside of the app, so they are safe and secure: they won’t disappear during a reinstall.

Also, you could try resetting your preferences. See…

scrivener.tenderapp.com/help/kb … references

Good luck.

aravindhrs - could you please zip up the project and send it to mac.support AT literatureandlatte.com, marked for my attention? If the progress bar gets stuck and the project never opens, that sounds like a bug and I’d like to see what is going on.

Thanks,
Keith

When I open the application, it automatically doesn’t open any project. It simply opens the templates window, and I choose the project. This particular project is problematic, and I do not get a error message or warning at any stage.

I tried opening from within Scrivener, that didn’t help either.

I wasn’t locked out of the project. I saved, compiled and quit the project before moving onto another.

As for the content package, thanks. I made copies and tried to fiddle around. The difference between the usable back-up and corrupt file was a file “user.lock” I tried opening after deleting that file, but still had the same problem. But with the RTF files I hope can rebuild the lost work, though it might bring up a lot of formatting issues. I’ll keep it as a last ditch option. As of now I’ll try to contact the software’s technical support team.

Scrivener isn’t the problem, the project file is. Other project files open fine.

Thanks Jo

Thanks Keith. I’ll mail the zipped project file.

Good that Keith is helping direct. I am confident that he will find a solution for you. Intrigued to know what caused the issue.

What was the problem and solution?

I’ve just purchased Scrivener 3 for my Mac.

Yesterday I imported a project and this morning, through the Scrivener “Open an existing file”, I was unable to do just that. However, I was able to do so through the ‘File’ tab in top left-hand corner, on my Mac (primary use). However there’s nothing on my Macbook and I now have another problem; there’s no sync between my Mac (primary use) and my Macbook.