Question about compile

Compile will only compile files in the drafts folder?

Is there a way to automatically designate another folder the drafts folder?

Yo, mclark.

Nope. As you discovered, the Draft folder is MAGIC when it comes to compile. MAGIC, like other SUPERPOWERS, is not transferable. Well, I guess Rogue in X-Men can borrow powers, but that’s a special case.

If it’s a permanent switch you are after, the Draft folder (in addition to being MAGIC) has no ego! It’s happy to be renamed to anything you like and doesn’t get at all jealous if you rename some other folder Draft (although that other folder might feel guilty about pretending to be the draft folder despite not having MAGIC).

Nope! You can also compile Collections! Create a new Collection, add all the documents from the binder you want compiled into it, and then you can select that collection from the Compile pane to use that instead! Wooooo!


You know, I don’t think this really is decaf.

Thanks for the info and the funny reply!

It looks like Collections have no heirarchy. Does this mean I need to manually add every scene to a collecton?

I’m using Scrivener to manage a collection of short stories. I had thought I could simply compile each short story in its own folder as I finish it. Due to the MAGIC of the Drafts folder, it seems I’m hitting some management issues which interfere with the writing. Do I have to swap stories in and out of the Drafts folder in order to compile them?

Anyway we can spread the MAGIC of the drafts folder in future versions?

If you have each story in it’s own folder, then in the expanded compile window, go to the Contents Section. There you should see “Draft” in a drop-down button; click on that, select the folder for the story you want to compile, then click compile. It will (mostly) treat that sub-folder as if it were the Draft folder itself.

This is how some people deal with books in a series, btw; each book gets its own sub-folder

Okay, I get it now. I think. I was using the Short Story Template. This renames the Drafts folder as ‘Short Story’. The name made me think only one story could exist there. Renaming it ‘Short Stories’, and adding another folder for each story seemed to have solved the issue.

Thanks for all the replies.

Ah, yeah. Same could be said for the singular form of Draft (blank template) or Manuscript (novel formats). By the way, if you want to compile all of your short stories into one volume, you can put all of their folders into the Short Stories folder, and switch the compile to the E-book or Standard Manuscript format preset, then customize the formatting from there; it will treat each story folder as a chapter of the overall book.

Sorry to butt in here but I have a question concerning compiling a collection of Short Stories . . .

I’ve got a collection of short stories set up and when I compile them Scrivener labels each story as “Chapter #” with the Short Story title as a subtitle. How do I suppress the “Chapter #” part?

I am otherwise getting exactly what I’m looking for in the compile.

That would be the formatting pane of the compile window you’re after. Probably for the folder “Lever 1+” line. There’s a button for “Section Layout” that should lead you to something that looks like “CHAPTER <$n>” or similar. Just delete that part, and you’re golden.

Quick addition, after selecting the row in the top section of the Formatting compile pane, you’ll need to click the “Modify” button below to open the window where you’ll then see the “Section Layout” button Robert’s describing.

Thanks folks! That got me where I needed to be!!

I’ve finished my novel and have oh, just a bunch of compile questions, but I’ll address 'em one at a time.

Mashing the buttons FILE->COMPILE->FORMATTING gives me a matix:

On all, the check boxes in the TEXT column are the only ones checked;

After compile, in the Word document, I get:

  • The Header page,
  • A page with ‘CHAPTER 1’ (centered) with the title beneath it (This line off center to right, by the way). Then on the next page, my chapter name is (I use ‘.1’, etc for the names) thereafter are at the tops of their pages, but also slightly off centered to the right.



(Top of next page)
(My Chapter Name)

(Top of page following end of chapter)
(My Chapter Name)

I’d de-selected the TITLE column boxes; Why does this little darlin’ put ‘CHAPTER 1’ above the title on page two, yet not on subsequent chapters?


Take a look at the previous answers to Maredudd. The path to the title prefix, where you can eliminate the CHAPTER designations is there, likely for level 1 documents and level 1 folders only. The title checkbox is to include/exclude the name of the folder or document that matches up to each of the level rows.

Thanks, Robert.

You know what else helped? converting my chapter containers from files to folders:

Right click chapter container -> Convert to Folder

After doing that, subsequent chapters were prefaced with CHAPTER (X). Then using your input, I discovered how to eliminate the folder names (X.) and use the CHAPTER (X) at the beginning of each, which is what I really wanted.

and then…

The next portion of my show just recently popped up. Having really screwed up the Format As’s that I’d prepared, I fell back and punted by selecting the Novel Std, MS Format.

Now I’ve managed to eliminate the Title Page. The string “Chapter One” one line below 'by (Yours Truly)

How do I manage to get the title page back, and Chapter One to begin on p.3? If need be, I’ll include settings in the Format matrix. Thanks again, Cousin!


Your title page may be in the trash. You can just drag that back in place, or create a new title page document. Format is how you’ll want it to appear, and check the As-Is checkbox in the inspector to keep it from getting a “CHAPTER X” designation.

I’m not sure if you can get the pages to start from 1 on the third page, but you can mess with the header settings in the Page Setting compile pane to not include the header on page one and to not count page 1 as well. You may have to tweak that bit in another word processor once you’re done with Scrivener.

Hope that helps.

Thanks again, Robert. If worse comes to worse, I’ll import the work to another template and start anew; I’ll try your suggestion, and continue fiddlin’ around with the little darlin’ a little more. If I can figure out what it is I’m trying to do, I’ll post the mysteries here… in case another Pilgrim has the same problem. You’re a Gentleman and a Scholar, and a good Judge of Fine Whisky.



Attempting to get text off of the header page:


  • Changed Folder Seperator to ‘page break’;
    Chapter One no longers below the BY line on the header.


  • I checked AS IS for 1st Page Header and Title Page (latter is a folder, actually).
    Title Page still didn’t show up. Now have CHAPTER (X) showing up between individual documents, probably due to screwing around with things yesterday. Progress, though.


  • I Checked Top FOLDER 1+ under Text Column.

Title Page is back, however Folder names are on a separate page as well, the rest still as before.

If that brought back the title page but put the folder names on a separate page, I’ll want to keep it, but should change a Separator. Which…?


  • Changed FOLDER SEPARATORS to Empty Line.

OK, Folder Names are now on a blank page, centered. I can live with that.

Now, to eliminate TITLE (X) from each section (document) head:


-Eliminate ‘Title’

No discernible effect.


  • Eliminate ‘Chapter <$t>’

No discernible effect. Replacing it


  • Eliminate ‘Chapter <$t>’

Success! The results are:
Header Page
Title Page (although the title is at the top, rather than centered vertically)
Chapter Page
Chapter Page

It was helpful to:
Make one change at a time and compile;
Keep a log of changes and order of buttons mashed.

Maybe the manual specs out which level is pertinent to what, but if not, an image with an explanation would have been useful. I’m finding the User Manual cumbersome and sometimes repetitive, but Help documents rarely get the attention as the software they accompany, at least that’s been my experience.

Thanks again, Robert. You all have a pleasant week!