Questions about linking to the Web

I have experienced inconsistencies when trying to link a note to the Web.

  1. When I used “Add Link” to add a Web link to a PDF and then exported the Scapple document to PDF, the link was not available in the PDF.
  2. When I dragged a Web link into a note with other info, more often than not the dragged link did not display in the note as a hyperlink.
  3. However, when I dragged the Web link into a new note and then exported it to PDF, the link usually appeared as a hyperlink in the PDF.

Overall, I have been pleased with how Scapple 1.2 works.

Howard

Are you saying you’ve created a PDF file (perhaps with Acrobat Pro?) and added a hyperlink to the PDF? I presume then you dragged the PDF into Scapple, and then saved that as a PDF, and the link within the PDF within the PDF isn’t working? If so, that makes sense (convolutions aside)—the link within the PDF in Scapple shouldn’t work either—at that point it is just considered a graphic, not a document.

The question then would be what conditions are different when it works, from when it does not? Even something so specific as the URL itself could be important. What you are dragging from could even matter. Is the cursor in the middle of the note, at the end of it? Anything could be significant. :slight_smile:

To answer what you asked in the first part, I dragged from the address bar of my browser (Safari) an address ending in PDF (not from my computer) and pasted that into the “Add Link” box.

Howard

Here is what I tried, it seems to be working over here, do these steps fail for you?

  1. In Scapple, hit Cmd-N to make a new board.
  2. Cmd-Return to make a new note, typed “link this”.
  3. Selected the word “this”, and hit Cmd-L to add a link to it.
  4. From the SeaMonkey web browser (same engine as Firefox—but I also tried Safari since that’s what you’re using), I dragged this URL, by clicking on the URL icon and dragging it into the Add Link text field.
  5. Clicked OK.
  6. Hit Shift-Cmd-E to save as PDF, and saved that as “Untitled.pdf” to my Desktop.
  7. Opened that in Skim (I also tried Preview), clicked the link. The PDF started downloading from the browser.

I tried to add a link twice. In my first try, I pasted the PDF’s URL into “Add Link.” In my second try, I dragged the PDF’s URL into “Add Link” from Safari. Then, I converted my Scapple document (attached) into a PDF (also attached). Though both links work in the Scapple document, only one works in the new PDF: the link I dragged in the “Add Link” box does not work.

I am running the latest version of Scapple on Yosemite.

Howard
Link test-1.pdf (15.4 KB)
Link test-1.scap (4.11 KB)

Interesting. Well it probably has more to do with the URL than the method used to populate the Add Link text field itself (copy & paste and drag & drop on a Mac are fundamentally the same thing, the main difference being that drag and drop uses a temporary pasteboard that is wiped as soon as you let go of the button).

Furthermore, when I export your .scap file myself, I get a functional second link in the PDF—very perplexing. Your PDF definitely does not have a link though, I can see that well enough, I’m just now sure how it got to be that way.

I’ve examined the URL, but there doesn’t seem to be anything wrong with it, or even particularly odd. One is using encrypted HTTP protocol and the other plain-text. You could maybe try right-clicking on the second link, editing it, and taking the ‘s’ out of ‘https’, export again and see if that makes a difference.

Let’s try this, with this same test document, export to RTFD instead of PDF and open that in TextEdit. Do you see the link there? If so use the File/Export as PDF… menu command and see how that works. Note that TextEdit will not adorn hyperlinks, but if you mouse over them you should get the hand pointer and clicking them should open them in a browser.

So that is two things to try:

  • See if http instead of https works.
  • See if exporting the document to a normal text file and saving as PDF from there works.

I’ve done this with Noteability PDF’s.

I saved PDF to my home screen and Dragged and Dropped it onto to Scapple

PDF is now veiwable in Scapple as a document.