Questions about MLA Paper Template

I just downloaded the trial version of Scrivener 3 and am using a MacBook Pro.
With regard to the sample MLA Paper Template,

  1. How did its author get the writer’s last name to appear in the header before the page number?
  2. In MLA, the correct date format is day-month-year, as in 2 Dec. 2017. Is there a way to set it up so that the current date automatically appears in that format?
    Thanks,
    Howard

Hi Howard,

.I’ve just had a look in the compile dialogue and it’s using a placeholder <$surname> in the Header. (Placeholders just tell the compiler to fill in information from elsewhere, or how to format that information etc.)

It’s picking this Surname up from various sources, in reverse order.

  1. Your contact details in the Mac’s Contacts app (unless you told it not to when you first opened Scrivener). Unless you’ve overridden it by

  2. filling in the details in Scrivener’s Preferences > General > Author Information. Unless you’ve overridden that in…

  3. Compile. In the header of the right hand panel, you’ll see an icon like a luggage label (to the left of the gear icon). Click on that and you’ll see a few fields, one of which is Surname.

I.e. The information in 3 will be filled in automatically from either 2 or 1, but you can override it here if you want to.

Changing the date…

On my (UK) system, the front page says 2 December 2017. What are you seeing?

If you look in the binder at the document Title, you’ll see a couple of placeholders. The date is taken from <$longdate> which picks up your Mac’s long date setting. ie in System Preferences > Language & Region > Advanced > Dates, I have the standard British format for long dates — ie 2 December 2017. This is correct for us.

You will see the long date format for your region. If that’s not what you want, but you see the right format in System Preferences, then you use a different placeholder. For the UK, 2 Dec 2017 (no full stop, because we British hate unnecessary and outdated punctuation conventions) is the Medium Date format. So all I’d have to do is change the placeholder in the Title document from <$longdate> to <$mediumdate>. You may have to choose a different format but the principle’s the same.

If you think that you still need the full stop after Dec, then if it’s not already there in your local formats, you’ll have to add it in System Preferences (just type it in the field after the month and it will be default for that format for your computer from now on).

Hope this helps

Hi,

You set the author name in the Metadata area of Compile. So, when you open Compile, you see the contents on the right. Above that are some buttons. You click on the tag icon to show Metadata, where you can set the title and author.

The date on the title page just uses the <$longdate> tag, which grabs the long date from the System Preferences, so its format depends on how dates are set up to appear there. There’s no way to set a specific date format in Scrivener, I’m afraid.

EDIT: Looks as though Brookter beat me to it!

All the best,
Keith

First time ever… I can retire happy :smiley:

Thank you very much. Your information enabled me to solve my problem.

Howard