Questions about pictures and compiling.

I’m writing an article with a number of illustrations in it. This is the first serious thing I’ve done in Scrivener since getting my Mac so I’m not fully familiar with it all yet (yes, I’ve done the tutorial) so I have a few questions.

1 - I know there are few serious formatting options but just want to check whether I’m right in thinking all I can do with pictures is scale them and change the justification? e.g. can I add automatically numbered captions or flow text around the pictures?

2 - When I paste a large picture in and scale it down so it all fits on the ‘page’, is the graphic file reduced or is it simply visually reduced?

3 - I have a section with several (originally) large pictures and (too often) get the colourful spinning ball thing showing it’s doing something (saving, I guess). I’ve set the auto save down to ‘after 10 seconds of inactivity’ but it still happens too often for my liking and during periods of activaty, interrupting my flow. What can I do to fix this problem?

4 - Is it possible to compile a version of the doc without the pictures? I want to print a copy off with only the text included for purposes of editing and printing all the pictures at this stage would be time (and ink) consuming for no reason.


Hi Andy,

You’re right that you cannot flow text around images - that requires some serious layout, so is left to external programs. You can create captions, though, using placeholder numbering. See Help > Placeholder Tags List… for more on this. Here’s an example, though:

The $n tells Scrivener to use regular Arabic numbering; the “image” bit is an arbitrary keyword you choose to tell Scrivener this is a single numbering stream; the last part is a unique identifier for this particular image. There’s some other cool stuff you could do with Compile Replacements to make this easier, too (for instance, so that you just typed “[img:hairyorange]”), but I’ll leave that for another time - I got halfway through a tutorial on all of this and must get around to finishing it…

It’s just visual. Thus, if you close and reopen the app, you can size it back up again and you won’t lose any quality to the image.

You could make the auto-save period longer (via the “General” pane of Preferences). Or reduce the file size of the original images. The trouble is simply that the text file is large because of the image data, so takes a while to save. Alternatively, you could store the images in the a folder alongside Scrivener and import them into the text using Insert > Image Linked to File… This won’t import the images into the text at all, but will just cause Scrivener to load them from the external file. That will keep saving fast, because the image data is no longer stored in the RTF.

There’s not, but it’s on the list of possibilities (with no promises) for 2.4.

Hope that helps.

All the best,

Thanks Keith, that’s very helpful advice. I’ll look into those things.


Just a suggestion and I don’t know if it would work … I just leave inserting images to the Nisus Writer Pro (for me) stage:

Have you thought about putting the images in separate scrivenings? If you did that, you could have the appropriate text in the scrivening above and the scrivening below. You could then

(i) work on the text without having the image(s) loaded in memory which might help with the autosave problem — one of the real experts will have to confirm :slight_smile:

(ii) simply untick the image documents from “Include in compile” for those times when you wanted a quick compile without them, and re-include when you wanted a full compile.

Just a thought. Keith’s approach is likely to be much better :slight_smile: … or you could try a combination of both? :confused:


Hi Mark,

No I hadn’t thought about having the pictures in their own documents - great idea!

Keith’s suggestion of using ‘Image Linked to File’ seems to have fixed the saving problem and I’m sure your suggestion will allow me to print out a copy of the text only (not as convenient as having a tick box to stop graphics being included when compiling but it’ll do for now)


It works. I split the graphics into their own scrivenings, changed the label for these documents to ‘picture’ then when compiling, on the ‘Contents’ page set the Filter to exclude documents with the label ‘picture’

A pain to setup but it does the job for now.