Questions on centering, font changes, & images at print-

A few print formatting questions:

  1. At various points inside my text I use a * * * symbol to indicate a break in time or scene to the reader (these are in the middle of a text document, not between them). When I print the manuscript my centered * * * comes out left aligned instead of centered. How can I tell the print engine to center the items that are centered in my text.

  2. Other than turning on “Keep Formatting” for a whole text document, is there a way for my chapter titles (which are at the top of the text document) to print in a different font than the body text? On screen the chapter titles use Arial, Bold, 22pt, while the body text uses Times/12pt. At print-time the print engine changes everything to the text specified on the printing dialog box (just like it’s designed to do), but what if I want the chapter titles to be a different font?

  3. In my document I have a few small and simple images that I have inserted into the text document. I see how I change their size. Is there a way to tell Scrivener to wrap the text around the image (rather than break the text, show the image, and then restart the text, leaving a large white space on the side(s) of the image).

All these questions may be in the “Scrivener is not designed to be a word processor” category. Perhaps the stuff I’m trying to do is too “layout” oriented. Or, perhaps, I just don’t know yet how to do them in Scrivener.
Either way, thanks for a great product. I love it.

Hi,

As you’ve noted, the formatting gets overridden by the Compile Draft settings. You have several options, though:
a) Choose not to override the formatting at all via the Compile Draft > Formatting pane.
b) Choose not to override the formatting for that document via Preserve Formatting.

I doubt the above are really what you want to do, though, so two better options would be:

c) Choose only to override the font via Compile Draft > Formatting (“Font only”).
d) (And this is probably the best choice, as it’s using a feature how it is intended to be used…) Place the different sections in different text files. Then, in Compile Draft > Text Options, from “Separate non-folder sections with” select “Scene breaks” and enter “* * *”. This will then automatically be placed, centred, between different text documents (but not between folders or between folders and text documents). NOTE: In answering your question I have noticed that for this to work, you must have Compile Draft set to override your text formatting. I don’t know why I set it up like that, so I’ve fixed that so that it will work regardless of whether you override formatting for the 1.11 update (out soon).

Again, two different options:
a) Don’t write the chapter titles in the document at all. Instead, make sure that the document has the title you want, then choose to include titles in Compile Draft > Content and set a different font for the title in Compile Draft > Formatting. If you don’t want the title of every document printed, then simply make sure you place all of your chapter documents inside a folder that has the title of the chapter. Then just set folders to include their titles (but not their text) and text documents to include text only (not titles).
b) For even more control over the chapter title format (perhaps including a subheading), again use a folder to hold the text documents that will be combined together to make the text of the chapter. Then, in the text of the folder (viewed by selecting the folder then deselecting the corkboard), set out the title as you want it and set the folder to preserve formatting. This is how it is done in the Novel Standard Manuscript Format template.

This can’t be done in Scrivener - it is something not easily achieved with the standard OS X text system, and definitely falls under the more complicated page layout that lies outside of Scrivener’s scope.

Hope that helps!
All the best,
Keith