Quick Reference Panels Not Working Properly

Hi L&L,

I’ve looked for this topic but couldn’t find it. I have a peculiar problem occurring. While revisiting the tutorial, I went to perform Step 12, under Part 2: Organization, and everything works fine…if the windows are minimized, but as soon as I click on the green button for full screen and hit the space bar for a QR panel, the Quick Reference panels open up in the background. Any idea how to fix? My Quickview works fine for other documents on my desktop. Also, the QR panels react perfectly when I press the toolbar icon or when I use Spaces on my Mac (go to another and come back and there the QR panels are!), but not when I press the spacebar. It’s almost like they’re invisible, because when I click the spacebar again, the drop down menu only appears.
I use these quite often in my novel project. Will someone please advise?

Best,
Michael

No response?
Has no one experienced this?

I don’t see anything unusual, but I’m not entirely sure of what the problem is?

Well, I tried describing it the best I could in the original post. The QR panels do not show up at all when I’m in full-screen mode (not composition mode, which also causes them to not behave properly).

Does the Window -> Float Quick Reference Panels command help?

Katherine

Thank you so much, Katherine. It worked! (Although, I had tried that I now clicked on Float Window as well, and that seemed to do the trick. Not sure why. Thank you! :smiley:

Meh.
Spoke too soon. The QR Panels still don’t work right. Whenever I’m in full screen mode, the panels always open behind the main scrivener window. It’s only when I toggle float off and then on again, do they show up. So, I cannot simply press the spacebar for them to show up, like instructed in the manual and tutorial.

I’m using 10.9.5 with Scriv 2.8.1

I’ve tried to reproduce your problem and simply cannot. For me, the green button maximises the window vertically but leaves it “as is” horizontally. So I manually resized it to fill the entire screen.

I then tried all those tutorial steps with “Float” both on and off. I even quit and relaunched Scriv. However, on all occasions the QR panels open IN FRONT OF the main window.

Which Mac OS are you using and which version of Scrivener?

Thanks for trying.

I’m using OS 10.12.6 and Scrivener 2.8.1.

I think it has something to do with the Floating Window>Float Window command being ticked prior to full screen or something.
It’s weird, if I press the spacebar, only the labels are highlighted in front of the main window–as if the QuickPanel is invisible; however, it’s behind it. The screenshot shows what happens after I select a document in the binder and then hit the spacebar.


Screen Shot 2017-09-15 at 12.19.26 PM.png

I hope everyone can see that the above is the drop down field in QR panel, but without the panel! The panel is actually behind the main window, and it does this everytime I click the green maximize button for full screen. Whenever I use regular view (not full screen), QR panels work fine.

I even performed a clean re-install of macOSsierra, and the QR panels do not open in full screen.

One thing from your screenshots - you appear to be in corkboard mode. I don’t know if it’s just me, but I cannot select a Binder item in Corkboard without the editor switching to normal editor mode, i.e. it leaves Corkboard.

I hate answering a question like this; you’ll see why. If it’s reproducible, maybe Keith can explain the reason for it. I’m on macOS 10.12.6 and Scrivener 2.8. I had the same experience as shrumpkin. In full screen using the spacebar, QR panels would open behind the editor.

QRs started opening in front when in full screen after I went to:

Finder Preferences > General > untick box Open folders in tabs instead of new windows.

After doing that, in Scrivener I left Float Window and Float Quick Reference Panels unticked. In full screen using the spacebar, QRs now opened in front.

Next I rebooted then re-ticked the Open folders in tabs instead of new windows in Finder Preferences, then tried a few Scrivener projects. QR panels are still opening in front in full screen. Don’t know if that’ll survive a reboot. I’m out of time.

Maybe it’s a just coincidence but it’s worth a try.

EDIT: I saw ScriverTid’s post after I posted. I wasn’t in Corkboard mode during my troubleshooting session.

Thank you, scshrugged, it worked! I do hope Keith comments on why this is so; perhaps the os commands behind the scenes for the opening of windows conflicts with the QR panels.

I tried exactly what you explained: Finder > Preferences > General > untick box Open folders in tabs instead of new windows.

ScriverTid: I wasn’t in Corkboard mode exclusively, but had a split–as you might be able to tell in the far-right pane.

Best,
Shrumpkin

You’re welcome, shrumpkin. Thanks for reporting back.
I’m not sure if this behavior is limited to the software versions* we’re using. Best as I can remember, I hadn’t tried this Scrivener workflow until this thread. If it carries over to Scrivener 3, L&L will likely address it somehow. Scriv 3 is their primary focus. For now, it’s easy enough to get it working the way you want. Yesterday:

Today I powered on (machine had been shut down overnight) and didn’t change any of the above. QR panels continue to open correctly. Note that the testing in yesterday’s last paragraph and today were done after I’d re-ticked the Open folders in tabs instead of new windows in Finder Preferences box. I bring it up because it sounds that the relationship between that associated OS code and Scrivener’s is being maintained in a system cache. Regardless, that’s above my pay grade, if you were to make a change in the OS, such as booting into Safe Mode (SM clears some system caches and attempts directory repair), you might have to reestablish the relationship.

*Yesterday I posted that I’m using Scrivener 2.8. To be more exact – I’m using 2.8.1.2.

I hope that L&L keeps an eye on the causes for this behavior, especially in the upcoming version.