Quick Search - Session Word Counts disappear

Recently I hovered over Quick Search bar and saw both Project (A/B) and Session (X/Y) counts. Later I saw only Project counts and can’t figure out what happened to Session, even after studying manual and menus.

Here is the first scenario that seems to have caused it:

  1. Mistakenly had Compile set to off for a document. (Not a factor I believe)
  2. Hovered over Quick Search to see my word count, saw both Project (A/B) and Session (X/Y) counts, Session was zero/zero.
  3. Turned Compile on, and continued. (Not a factor I believe)
  4. Closed my laptop to go home (after 34 words) and when I logged back in the 34 Session word count showed in Project Targets but the Quick Search showed only the Project word counts (Current Total/Projected Total). Even after closing and reopening, quitting and restarting Scrivener, the Session word counts are missing.
  5. The next time I logged in to my computer the Quick Search was back to showing both Project and Session counts.

Here is the second scenario that seems to have caused it:

  1. Quick Search is normal.
  2. I entered Composition editing and when I returned (via Esc) to the document the same thing occurred as in the first scenario. Only Project word counts and Session Word Counts were missing.

I have tried to reproduce this based on your description but so far have been unable to. Can you reproduce it every time? Is there a particular series of steps that causes the issue every time?

Thanks and all the best,
Keith

I could not seem to replicate it consistently except scenario #3. I will give you the scenarios that made it happen, but the last scenario is a definite and very bizarre! It could possibly explain the others without me knowing it at the time.

  1. I wrote 3 words in a current scene, changed to another scene to look at something and session count was in search bar. Had to log back in after being away from computer and session word count still there. Typed a sentence and it disappeared.

  2. Once the session count disappeared in most other scenarios (which I couldn’t figure out what made it happen) it didn’t return until the next day when a new session began (mine are set to start new at the beginning of each day).

  3. Session count stayed even when I tried to replicate #1 another day. When I was back in the starting scene that I was originally editing I added words in the middle of the last paragraph and the session count went away at some point. I went to the end of the paragraph and deleted multiple words and surprisingly the session word count returned. I then created a new file for a new scene and it was still there.

    • I typed 1 word and it disappeared.
    • I deleted the 1 word and it came back.
    • I typed the first word and it disappeared again.
    • I typed word 2 and it came back.
    • I deleted word 2 and it disappeared again, doesn’t appear until I type the first character of word 2.
    • I typed word 3 and it disappeared.
    • I deleted word 3 and it came back, doesn’t disappear until I type the first character of word 3.
    • It never appeared again until I typed word 8.
    • It disappeared at word 9.
    • It returned at word 12.
      -It disappeared at word 13, doesn’t return until word 18.
      I stopped monitoring after that.

I’m afraid I still cannot reproduce this, and I’ve looked at the code and cannot find the obvious cause there, either. If you can find a specific set of steps in either a blank or specific project that always causes the problem, I’d be very grateful if you could share them.

Thanks and all the best,
Keith

Just to be clear, I’m using Mojave OS and Scrivener version 3.1.1
I will update to version 3.1.2 now, but all of this was under 3.1.1 and I didn’t see this addressed in the update info.

I’m not sure if this is what you’re asking for, but I was able to recreate the following scenario twice with the same result based on the number of words despite the actual scenarios being slightly different. I’m not sure if changing documents matters but 99 seemed to be the magic number this time.

(Quick Search session actual/target word counts are there until I state otherwise)
a) I began typing in Document J, reaching 99 words exactly when I needed to confirm something.
b) I selected Document H to verify it (no split screen) and session count was still 99 out of target goal.
c) I went back to Document J (no split screen) and count still 99. Began typing and the actual/target session count disappeared. I had no clue why so I kept going.

Next day:
a) I began typing in Document J, reaching some number of words (forget exact number, maybe 20-some).
b) I selected Document H and typed some words (maybe 10), all is okay.
c) I went back to Document J and typed more words reaching about 44 overall in the Quick Search results.
b) I selected empty Document K and typed 55 words for a total of 99 in the Quick Search results. Without going to another document I typed 2 words and the session counts disappeared again. I deleted the 2 words back to a total of 99 and the session counts reappeared in the Quick Search bar. I typed one word (total of 100) and it disappeared again.

Seems like a repeatable scenario. If this is not what you are wanting just let me know. Feel free to email me!

Sorry for the late reply. I still cannot reproduce this, I’m afraid. One thing to consider is that the Quick Search bar only shows the word counts when your mouse is over it - it couldn’t be something as simple as you moving your mouse, could it?
All the best,
Keith

No, the mouse isn’t moving. If the mouse moves off of Quick Search it shows the document title instead, so the only way I can see the session/target counts is if I keep the mouse on the bar. The Session Target information simply gets dropped and only the Project Target information is displayed in all these situations. It happens every day now after I have typed 9 words.

I opened a brand new project and without typing tens of thousands of words or copying in tens of thousands, I can’t replicate it either.
I’ve tried to think what may be different.

One is I moved my project from Windows 10 Scrivener 2 version (which might have been moved from Windows 8.1 Scrivener 2 version) to the Mojave Scrivener 3 version. So I opened it after the move and it asked me if I wanted to convert to Scrivener 3 and I said yes. Would that cause any residual code to be there, or some such?

Two is simply the number of files and scenes I have that makes it unique from a newly created project. Nothing excessive and nothing should be so unique to cause it, but I don’t know.

I will post again soon with screenshots to show. Not sure what else to do on my end.

If it’s only occurring in one project, is it possible for you to share that project with me so that I can test it?
Thanks and all the best,
Keith

Sure, how do I share it with you?
I also just found out I can’t edit index cards in cork board mode and I used to be able to.
Interesting note, another project I have isn’t giving the same problem with word count so far. Must be my project.
You have my email, feel free to contact me and let me know because I check it every day.