RC 16: Crashed on 1st run

Crashed on 1st run.
Here’s the onscreen “Details.” There were no dump files.

This is the 32-bit version, running in a Win 7 guest Virtual Box (x86) on a Linux host.

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 Segoe UI;}{\f1\fnil\fcharset0 Calibri;}} {\colortbl ;\red0\green0\blue0;\red0\green102\blue204;\red0\green0\blue255;} {\*\generator Msftedit 5.41.21.2510;}\viewkind4\uc1\pard\tx90\tx2880\cf1\f0\fs18 Problem Event Name:\tab APPCRASH\par Application Name:\tab Scrivener.exe\par Application Version:\tab 2.9.9.16\par Application Timestamp:\tab 6011da21\par Fault Module Name:\tab StackHash_3d8c\par Fault Module Version:\tab 6.1.7601.17514\par Fault Module Timestamp:\tab 4ce7b96e\par Exception Code:\tab c0000374\par Exception Offset:\tab 000c37b7\par OS Version:\tab 6.1.7601.2.1.0.256.1\par Locale ID:\tab 1033\par Additional Information 1:\tab 3d8c\par Additional Information 2:\tab 3d8cb091d7a2427494c3a00a18c1ba6b\par Additional Information 3:\tab 38f3\par Additional Information 4:\tab 38f3ea2ebca68c675fc5f36d57a9c5c2\par \par \cf2\b Read our privacy statement online:\par \ul\b0{\field{\*\fldinst{HYPERLINK "http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409"}}{\fldrslt{\ul\cf3 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409}}}\ulnone\f0\fs18\par \par \cf1 If the online privacy statement is not available, please read our privacy statement offline:\par \cf2\ul C:\\Windows\\system32\\en-US\\erofflps.txt\ulnone\par \pard\sa200\sl276\slmult1\cf0\lang9\f1\fs22\par }

I installed twice, once without the api-ms-win-crt-runtime.dll and the other time with it (separate directories); this is from the second install.

Hope that helps. Don’t see anyone else having this issue, so I’m assuming either they’re silent or I’m unique. Suggestions?

Note: I’ve made sure that dot net is up to date (4.8). Still fails on running.

And when I run Scrivenerlog.bat, scrivener runs just fine. Very interesting.

Check disabling the Auto Update(which is a known issue). If this does not work we cannot help much as the crash happens in a module version 6.1.7601.17514 and Scrivener does not use directly a module with that version. Sorry about that.

But a search on that module version turns up an audio driver circa 2012. Just the sort of subsystem that would trip up a few users among many, let alone under emulation.

answers.microsoft.com/en-us/win … cc85ed2d87

Rgds - Jerome

If anyone else has this issue, turning off “nested paging” in the Virtual Machine appears to stop it.