RC11 -Style disappears when adding paragraph inline

Moving this over from the bug hunt forum (which is apparently the wrong one):

Very happy with current RC, using it as my primary writer. However, noticed an issue:

I use my own style for the text (in novel format). Whenever I’m adding a paragraph in the middle of the text, the new paragraph always shows up in the (what I assume is the) default style.

To reproduce:

  • apply custom style to enter section.
  • at end of any paragraph (except the last), hit enter to start a new paragraph.

To mitigate:

  • go to start of following paragraph
  • delete backward until they are one paragraph
  • enter twice to re-break old paragraph and create new one.

NOTE: Don’t know if this affects things, but my document was originally created in OSX. The style did not come through when I opened it, so I created a new one. When I start working on a chapter, I select all and apply the style. I will also note that the style I’m seeing when I create a paragraph inline is not the style that was applied to the chapter when I first open it.

You can change the default style.

File
Options
Editing
Formatting

and apply whatever you want to be the default (which I’d presume would be your own format).
You could make an empty project, apply the defaults, and save the project as a template, so you could start each novel without creating a new style.

Also, at the end of the Style definition, there is an entry for formatting the next paragraph. If you have “None” entered there, Scrivener will apply the default formatting to the next paragraph. That sounds like what’s happening – you enter to create a new paragraph, and it applies the default formatting to it.

Here’s where you can find that:
[attachment=0]Scriv_style-dialog.JPG[/attachment]

You can, instead, use “This Style” in the dropdown, and Scriv will make the next paragraph’s style the same style.

Of course, if that’s the error (you’ve got it marked “this style” instead of “none”, and it’s ignoring the setting), then that’s a serious bug.

But it’s better not to apply a style if you can make it the default format. And if you always use that format, I suggest you make it the default. Of course, there may be reasons not to, but Scrivener (at least the Win Beta 3) works better when you do.

That does do it, though it takes an awful lot of tweaking to match the style propertly.

I’d still call this a bug, if the goal is to feature-comparable to the OSX version (as well as comparable to many, if not all, other word processors on the market).

But thank you for your help. It’s been months now, and it’s been driving me crazy.