[RC12] Images missing after quit and restart

I can seem to find the post that first reported this, but FWIW, images still disappear from a Binder doc after the program quits and restarts.

I tested this with RC11 with both embedded and linked images. It’s true of RC12 with linked images as well. Didn’t test it (yet) with embedded images — I’m kind of tired of re-added these images — but I’m sure the full problem is still there.

Thomas

This is the topic:

[url]https://forum.literatureandlatte.com/t/images-disappear-when-scrivener-closes/93224/1]

Thomas

FYI, the thread that you link to still doesn’t have an LH number in the thread title, which means that that L&L hasn’t officially entered it as a bug into their internal system yet – probably because they don’t have a solid set of reproduction steps for the devs to investigate. If you have a minimal set of steps that can reliably trigger the bug, post them in that thread, others of us will confirm, and we can usually get it assigned a bug number fairly quickly after that.

Then, all you have to do is see when that bug is listed as being fixed in the readme file for each release. :slight_smile:

Could you please record a video with the steps you make, that lead to the missing images upon restart. A simple video recorded with your phone, can do the job too.

I can try, Tiho, but that’s something I’ve ever done.

Is no one else at all seeing this?

Steps:

  1. Open a document.
  2. Insert a link to an image via Insert > Image Linked to File
  3. Save the document or wait a while till program autosaves.
  4. Close Scrivener.
  5. Open Scrivener and inspect the document. Image is gone.

It’s not like there’s some secret sauce to making this happen.

I’ll accept that I may be alone in seeing this. But is that really true? There was an earlier thread on this.

Thanks for trying. Just frustrated.

Thomas

Thanks, Devin. That’s exactly why I wrote this.

Best,

Thomas

I can confirm I’m seeing this with both “Image Linked to File” and “Image From File”, and it doesn’t seem to matter where the source file is located, either.

[attachment=0]MissingLinkedImage.jpg[/attachment]

The image was originally inserted just under the line “Linked image” and was visible. After close and re-open, it is no longer visible, and not only that, there seems to be some residue, because the “After text” line isn’t getting the right inter-paragraph formatting that it had before I saved – it should be spaced the same as “Before text” and “Linked image…” are.

Sorry guys, but I still cannot reproduce it. Tested both Insert > Image from File and Insert > Image Linked to File, but after closing and reopening Scrivener the images are still inside the document as expected. Try with a different image format, and upload some projects after the images are imported, please. At the moment we have no idea what is causing this.

Here you go – all files are in my C:\users\devin\desktop folder.

Thanks, Devin! I downloaded your project archive. Used the “Scale Image…” context menu to point the linked images to the new file paths located in your archive, and the images appeared. The images appeared also after a Scrivener restart.

Could it be the antivirus application blocking Scrivener from accessing some files?

Could you please try link to image files outside of the “Desktop” and “Documents” folders?

Try turning off your antivirus application too, if possible and reload Scrivener.

It all seems like something prevents Scrivener from accessing the external image files at the moment on some computers.

If someone else could test this and report the results, it will help too.

I’m using Windows 10, latest release build, with just Windows Defender. Disabled realtime protection, moved the image files to c:\temp, re-inserted them both Image From File and Image Linked to File, and saw the same behavior after closing and re-opening Scrivener.

Have you solved this problem yet?

RC15 still has this problem.

After I reset all the settings, the bug disappeared