RC17 - Scriv 1 project from iPad iOS 9.3 now doesn't convert at all

Hi @tiho,

I saw the item to fix this from the release notes, but unfortunately the situation is even a little bit worse

  • It appears that there’s now no conversion to a Scriv 3 project, no matter how you open it or how many times
  • no conversion dialog appears
  • no documents show, not even ones with synopsis – this is no doubt due to no conversion

I’ll include a screenshot, indicaing three documents via scrivenings view, plus a zip of the project after upload and opening.

Best, and I know how it goes,
Clive

[attachment=0]Gnu Gnu scriv.zip[/attachment]
[attachment=1]rc17-iPad-gnu-gnu-scriv.png[/attachment]

Ok, a little more information.

Without thinking, I outlined content for an important paper this morning early using the iPad. This project didn’t convert from RC17 either, once on the laptop Dropbox. So I went after some alternatives.

  • I created a fresh Scriv3 project intending to mirror, on the laptop
  • I attempted a manual Import of the failing orginal. This didn’t work better, but got me a named copy at top level in the mirror,
  • As we’ll see can be important, this copy on the mirror, like the unconverted original project, had its files invisible, but available as before in cards or outline view.
  • So, I did a file-by-file import of the original project’s rtf files, from within the project. This was tedious, because a) only generic titles, all the same b) synopses were separate files whos text needed copying in manually, and c) the files are each in a folder so you have to dig for each one.
  • This very manual method proves the point that we can always recover a project, but it occurred to me after that maybe there was a better way
  • Indeed, since the files were visible in Scrivener formats under the imported project if you used cards or outline, I tried just dragging them over via the items showing
  • This actually worked very well, the items appearing in the Draft of this mirror project complete with titiles and synopses, only needing to be ordered (and if needed, folders created) to be ready to use.
  • Though cards may seem a first choice, actually that honor goes to outline items – use those. Reason is that cards hide the drop point with their dragging image, while outline items are smaller, much easier to use.

So, that’s facts for Tiho, and a nice picture of how to recover if you ever do have trouble with a project sufficient to need that. Other than this moment where iPad conversions get complete in their implementation, I never have had the need.

Underlining that projects created originally on Scrivener Win 3 have always worked just fine, back and forth with my old 9.3 iOS-and-can’t-upgrade iPad.

Slight extra note: blank (any with no text etc. content yet) files don’t show up in the imported copy for pulling over, so you’ll need to create those manually, writing in their title…

You can best get those by opening the original on the iPad, first being certain that isn’t open on Scrivener Win 3.

Hi Clive, thanks for the report. Looking at the project attached in the initial post, I see three documents in the Draft folder, the first with no title (using placeholder text from the document) and the second two with their titles. Some sample text in each and synopsis text in the third. Is this correct? The text of the items is showing in the screenshot in Scrivenings mode, matching up with what’s in the project, so I’m not clear what isn’t working correctly here.

Could this just be an issue with the interface? I notice that the colour theme you have in the screenshot makes the collapse/expand chevrons nearly invisible, and the binder starts out after the initial mobile conversion with everything collapsed. You can expand via the keyboard using the right arrow key if mousing isn’t working easily.

I wasn’t able to replicate a problem of items from a new iOS project not appearing once opened in Windows, so if it’s not just an issue of the collapsed binder state, it’d be helpful if you could share a zipped copy of a sample project from iOS before it is opened in Windows. (Just zip the .scriv folder after it syncs from Dropbox, before opening it in Scrivener–then just make sure when you do open it, it is missing the items before sending the zipped copy.) That will let us test better to see what’s going on.

Hi Jennifer, and many thanks. I’ll try to connect us better on those points, and also put together a fresh test, so we are both aware entirely of how it’s constructed.

project content vs. screenshot: – I think you are seeing just as I do. I used the Scrivenings view to show that the documents and theiir content were present, in Scrivener’s view. The problem then is that the documents simply don’t show in the binder at all. Thus there’s inability to select or manipulate them.

before and after quastion: the zipped project was intended to be and should have been from before Windows Scrivener had touched it. To assure this point is why I’ll do the process again, and attach that surely fresh-from-iPad file, arrived via Dropbox.

question of the theme. Well, the theme shows documents fine whenever a project was first created in Windows, and does so also in that hybrid I made by creating the project first in Windows and then importing the again-blind iPad project, then as described, moving its invisiblle files into the fresh Draft folder, where they then showed. That’s probably a little hard to follow, but was just that simply done.

Underlying this is the difference in behavior between RC16 and RC17. In RC16, there was the dialog indicating Scrivener 3 recognized the iPad project needed to be converted from Scriv 1 framework to Scrive 3, but apparently didn’t actually do that conversion, as Tiho found. In RC17 there’s no dialog indicating the need was recognized and attempt made. No dialog also on import of the iPad project into the prepared Scriv3 project as an item.

The last point has me thinking that RC17 just never even recognizes the iPad project as a Scriv1 format, so that either opening it or importing it presumes Scriv3 format. Thus, in neither case are the Binder files getting updated so that they show the documents.

Ok, let me send you this explanation, and I’ll follow up with a guaranteed, fresh from iPad creation and thus Scriv1 project so we’re both entirely confident about that. My prediction is that when you and I open it, after the zip has been created and sent, that we will be able to see document content in Scrivenings, Card, or Outline view – but that we will also see no indication that the documents even exist, in the Binder…

Jennifer, as promised, a freshly made zip of iPad project.

And then, how it looks on the iPad, comparable with how it looks on RC17.

  • no conversion dialog was presented
  • none of the documents shows in the Binder
  • notice that there’s not a space for them, either, I think indicating the theme isn’t involved. Also, the repair project detailed above, the documents once transferred from import in any fashion show fine as expected. But anyway, I switched to default theme, and as you’ll see, this didn’t change anything.

Prior to opening the project in RC17, I de-installed RC17, then deleted its Program Files folder. Then used Control Panel to remove prior installation indications once again (will report on this separately), and deleted one folder of L&L’s found left in my user area AppData/Local from some very much earlier adventure with non-Admin install. I always use Admin install, and I run as non-Admin. Then installed RC17, and opened our project.

None of this made any difference, but we know the results are on a clean install.

zip of non-opened iPad project:
[attachment=0]Mouton’s Fresh Field.scriv.zip[/attachment]

iPad view of project:
well, the forum got a little confused about this, so I’ll add it on a fresh reply…,

RC17 view of project, Ocean theme:
[attachment=1]win10-scriv3-documents-as-cards-but-not-in-binder.png[/attachment]

RC17 view, Default theme:
[attachment=2]win10-scriv3-documents-as-cards-default-theme.png[/attachment]

…and here, I hope, is that screenshot of how this time’s test project looks on the iPad:
[attachment=0]ipad-ios9.3-as-cardswith-documents-showing.png[/attachment]

Thanks for the follow-up. So looking at this, I still think there may just be some confusion regarding the UI. When an iOS project is first opened on the desktop, the binder is collapsed to the top level, so you’re only seeing the root folders. But you should be able to expand the Draft and see your items in it. My point with the theme was just that the colouring of that one makes it hard to see the expansion chevron that might have more clearly indicated this; it’s visible in the screenshot using the default colours. That’s a separate issue, of course, that the chevrons aren’t appearing in a good contrasting colour for a range of binder backgrounds, but it’s not related to the iOS sync.

Another way to check on this would be to select one of the items in the corkboard and use the Navigate menu to Reveal In Binder. That will expand containers as necessary to show you the selected item.

After that initial sync, the desktop UI file is created in the project, so future openings on Windows will look the way you left the interface on the desktop. (Mobile and desktop have separate settings for this, since they’re naturally very different.)

Yes, this is the expected behaviour now because there’s no conversion that needs to be made. The project on iOS isn’t in a version 1 format, so now that the Scrivener 3 beta has been fixed, it’s not trying to deal with it as though it were. It should just be a smooth process for syncing between iOS and the desktop.

You know what, Jennifer? You’re right!!

A proof that we see what we expect to see, as the screen shot with the Default theme does show the arrow, and indeed the documents are right there when you use it.

In final check, editing new documents laptop or iPad synced fine , as always.

Apologies for the whole false alarm here, as indeed Tiho’s fix did work.

He’d explained in terms of a Scrivener 1 document here [url]https://forum.literatureandlatte.com/t/rc16-problem-with-easy-workaround-for-project-first-created-on-ipad/94547/2], but by your concluding explanation that was no longer the case (because I had latest iOS 9.3 compatible, seems likely) and so my clue of not seeing conversion as I did on the initial RC16 issue isn’t actually one now.

Nice to have it all, and a smile for the Mouton story :slight_smile:
Clive

Good, glad to know the sync is working correctly for you after all!

I did appreciate that. :slight_smile: