<RC7> Very slow startup for first document, or...?

Is it just me, or is RC7 much slower than previous releases when opening the first document after application startup?

Even an almost empty document has a noticeably long delay (5-10 seconds?) before showing on-screen, while later documents open as snappily as before. I don’t recall this happening with earlier releases.

The message Scrivener displays for 80% of the delay is “Loading spell checker engine”.

Not sure if this is relevant:

  1. The problem is only noticeable on my (modern) laptop, where I have tested both high-dpi and regular versions.
  2. My desktop PC does not show this issue.

Change the spell checking dictionary and try again. Try reinstalling the dictionary or using a smaller dictionary for the language.

I timed it, and the actual time it takes for the first document to display is 36 seconds.
Once Scrivener is active, opening another document is near-instantaneous.

I now believe that my earlier reference to dictionary loading may be misleading/irrelevant.

  1. I switched dictionaries without seeing any difference.
  2. More importantly, if I open Scrivener without loading a document, i.e. the Project Template dialog shows, the dictionary ‘engine’ has already been loaded (I think). Opening a document from Open Recent still takes the full 36 seconds.
  1. How big is your project?
  2. Are you opening in Scrivenings Mode?
  3. Is "Backup on open checked?

:slight_smile:

Mark

Hi Mark.

  1. As little as 5 words total in a single file/scene
  2. No
  3. No

Problem solved.

By analyzing Scrivener’s wait chain I noticed that the spool service was the ‘bottleneck’.

Apparently, Scrivener tried to connect to a network printer that was offline and was stuck in a non-responding state before timing out.

Solution: setting another default printer.