Re: Bug beta, compile missing part of the title

I don’t know if someone already mentionned it, but since the last 3 updates (maybe more), I have some compiling issues. It does not compile part of the title. But the chapter title (En forêt) and the text are OK. I did not change any option in compile window. I did update the chapter number style, though. But I also updated the chapter title style and there is no problem with it.

This is a printscreen of what it was doing before the last update this morning. Scrivener is in grey and Word in white. You can see the chapter number (which is a custom style I did) lost its style.

This is what it does since today’s update.
You can see that one picture and the chapter number are missing.

I am working with Windows 10.

It’s still doing the same, like the first picture. After compiling to a Word document, the number of the chapter loses the size that is included in its style in Scrivener. Why? I tried many times to update the style in scrivener, but it changes nothing. I hope the next update will correct the problem. Again, this problem happens only since maybe two months (maybe more, I dont’ remember exactly). Before that, everything was working fine, so I think an update created that problem.

What Style is that chapter number in, and is it that same style in Word? And what font size does that style in Word call for? Also, in your compile format, under Style Layout, at the botton, are you overriding text and notes formatting? Uncheck the box and see if that changes?

Hi, Thanks for your reply!
The style I use for this chapter number in scrivener is a custom style I created. In Word, there is no style assigned to it, all the text and titles have no style in Word, but keep the same font and size than in scrivener. Except that chapter number who just loses everything (font and size) in Word.

When compiling, I was not overriding text and notes. I did not see that, after one of the update, I had to assign another layout, because the one I chose was not assign anymore. So I chose “section text”. Still, it did not work. I tried with “As-is” “New page” and other, but the chapter number never comes out right.

But I noted something strange with that style. Everytime I quit scrivener and open it again, the style lost its size… weird… Another weird thing is that I created a new style for the chapter number and gave it a different name (without the drawing) and when I quit scrivener and open it again, the style stays the same. But, when I compile my chapter, it does exactly the same in Word by losing the font and the size of the style.

Please note that the other styles I use in scrivener, I created them from a default style that was already in scrivener (so I did not add a new style from nothing like I did for the chapter number). Maybe that is why… And also note that I am using a custom scrivener’s theme. I also tried erasing the drawing, and it does not help.

Okay, the last concerns first. There is no reason why a created style should be different from a default one. I do it all the time.

However… Hmm.

One the one hand, this sounds like a bug (that the font size doesn’t stick when you reopen Scrivener). But let’s rule out a common error, first.

So, the way I create chapter numbers… I don’t even bother with numbers in the document. I use <$n> once at the beginning of each chapter, make it the right font size. It’s part of a “Section” type, and I use Structure-based to determine that. Otoh, Section and Text I pretty much treat the same in compile.

I can have multiple documents in a row as part of the same chapter; when I need a new chapter number, I insert the <$n>, set the format to ChapNum (after defining ChapNum in the beginning), and forget it. You don’t have to do this. You can simply put a chapter number in that doesn’t autonumber. It is handy, though.

Here’s a pic of the style I often use to do this:

So my chapter number is literally part of a document’s text. No special layout for it.

Note the font size and family are saved with the style. Otherwise, the font will be whatever’s surrounding the text so styled. This may be the issue with the chapter number style not sticking (although, honestly, it should be saving the font size in the contents file).

You can redefine the style, also (Main menu, format, style, redefine style to selection, click the style you want to change, check the appropriate boxes, and click ok – should work). This should override any prior definition.

In project > project settings, make sure that in Formatting that “use different formatting” check box is not checked. That can cause you to pull your hair out in frustration.

In compile, make sure your styles aren’t being replaced, deleted, transformed or altered.

That box that says “override text and notes formatting” is the default; you’ll need to uncheck it in every section layout to get rid of it.

Final potential issue (that I can think of right now): your project may be corrupted. When a project corrupts, all kinds of functions behave oddly. There are several ways to fix this, but the easiest (my opinion) is to Open the project, Select all in the binder, copy, make a new project of the same type, and paste into the new binder. Rearrange to suit your needs, and try again.

Sorry I can’t be of more help, but that’s all I can think of right now as to why it would behave that way (no doubt someone else will have some other notion that may work).

Thanks again for your help!
And you did help because now it’s working! :smiley:
Let’s try to understand what the problem was.

That is what I was doing everytime I open Scrivener again, to redefine the style, because it was losing the font size.

It was not checked.

I had to edit the Section layout that I had chosen in compile, to uncheck that default “override text and notes formatting”. I did not realize that it was checked. So thanks for that idea! Though, I tried compiling again and it still did not work. I mean, the chapter number was still losing its size. But then, because you told me it could be a bug, I tried to use the new chapter number style I created the other day. Because I saw that this new style was keeping its font size and family when I quit Scrivener. So I applied it to my chapter number and then compile the chapter. And it worked!!! Yeah! :smiley:

So I think it was a bug and also that default “override text and notes formatting” that was checked.

So thanks again! The problem is solved! Even though I still don’t understand why that first chapter number style was losing its size everytime I quit Scrivener. I’m afraid it will remain a mystery… :wink: